vle-cdrassoc


(vle-cdrassoc  key  lst)

searches 'lst' list for a dotted-pair with key 'key' and returns its value;

Arguments

key  key value for the dotted pair value to search for

lst  list of dotted pairs

Return

the value of dotted pair (key . value), if a dotted pair with key key, if present in the list lst;
NIL if not present

Example

(vle-cdrassoc 11 '((1 . "a")(2 . "b")(11 . "xx")(22 . "yy")))
returns "xx"

Alias

vle-get-cdrassoc
vle-get-cassoc
vle-cassoc

Remarks

replacement for (cdr (assoc key lst))



©  Bricsys NV. All rights reserved.