vle-dictsearch


(vle-dictsearch  dictname  itemname)

verifies whether the dictionary 'dictname' contains an entry 'itemname'

Arguments

dictname  entity name of the dictionaty to search in

itemname  the entry name to search for

Return

 T   if the dictionary 'dictname' does contain 'itemname'
NIL if the dictionary 'dictname' does not contain 'itemname'

Example

(vle-dictsearch (namedobjdict) "ACAD_GROUP")
returns the ename of the group dictionary, NIL otherwise

Alias


Remarks

fast replacement for (/= (dictsearch dictname itemname) nil) and (if (dictsearch dictname itemname) ...)



©  Bricsys NV. All rights reserved.