vle-dictobjname


(vle-dictobjname  dictname  itemname)

verifies whether the dictionary 'dictname' contains an entry 'itemname' and returns the entity name or NIL

Arguments

dictname  entity name or string of the dictionary to search in

itemname  the entry name to search for

Return

the ename of the dictionary item 'itemname', if present;
NIL if the dictionary 'dictname' does not contain 'itemname'

Example

(vle-dictobjname (namedobjdict) "ACAD_GROUP")
returns the ename of the group dictionary, NIL otherwise

Alias

dictobjname

Remarks

this is a fast replacement for (cdr (assoc -1 (dictsearch dictname itemname)))



ACAD_COLOR


ACAD_DETAILVIEWSTYLE


ACAD_GROUP


ACAD_LAYOUT


ACAD_MATERIAL


ACAD_MLEADERSTYLE


ACAD_MLINESTYLE


ACAD_PLOTSETTINGS


ACAD_PLOTSTYLENAME


ACAD_SCALELIST


ACAD_SECTIONVIEWSTYLE


ACAD_TABLESTYLE


ACAD_VISUALSTYLE




©  Bricsys NV. All rights reserved.