vlisp-import-symbol
(vlisp-import-symbol
symbolOrList)
This function imports the specified symbol /
variable (or the list of symbols / variables) from the global
document namespace (where normal Lisp code is operating) to the
current VLX namespace.
It imports the actual value of the symbol /
variable, not a "reference" to the symbol / variable !
If the value is changed in global document
namespace, the symbol / variable need to be re-imported
again.
see (vl-doc-ref)
Arguments |
symbolOrList a single Lisp symbol (string or symbol) or a list of Lisp symbols |
Return |
the value of the last evaluated symbol / variable |
Example |
(vlisp-import-symbol 'MyVar1)
returns the value of "MyVar1" |
Alias |
|
Remarks |
if (vlisp-import-symbol) is
called from the global document namespace, then it does nothing and
returns the value of the last evaluated symbol /
variable; |
© Bricsys NV. All rights reserved. |