Scales this point by the scale factor about
the specified point.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point3d ScaleBy(
double scaleFactor,
Point3d centerPoint
)
Public Function ScaleBy (
scaleFactor As Double,
centerPoint As Point3d
) As Point3d
public:
Point3d ScaleBy(
double scaleFactor,
Point3d centerPoint
)
member ScaleBy :
scaleFactor : float *
centerPoint : Point3d -> Point3d
Parameters
- scaleFactor Double
- [in] Scale factor.
- centerPoint Point3d
-
Return Value
Point3d
3D point that is the result of the scale operation.
See Also