Point3d Structure

This .NET class wraps the OdGePoint3d class. This class represents points (locations) in 3d space. For more information, see Working with Basic Geometry Types.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryPoint3d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Point3d : IFormattable

The Point3d type exposes the following members.

Constructors
  Name Description
Public method Point3d(Double) Constructor for the Point3d class. Creates a new point with coordinates taken from the first three values of the passed array.
Public method Point3d(PlanarEntity, Point2d) Constructor for the Point3d class. Constructs a 3D point by the formula: p + uAxis * pnt2d.x + vAxis * pnt2d.y, where p, uAxis, and vAxis are returned by the function call plane.get (p, uAxis, vAxis);.
Public method Point3d(Double, Double, Double) Constructor for the Point3d class. Creates a new point with coordinates specified by the x, y and z values.
Top
Properties
  Name Description
Public property Coordinate  
Public propertyStatic member Origin  
Public property X  
Public property Y  
Public property Z  
Top
Methods
  Name Description
Public method Add Returns a new point as the result of adding this point to the specified three-dimensional vector. No actual coordinates of this point are changed.
Public method Convert2d Returns the 2D point with the coordinates corresponding to the decomposition of the vector * this - p in the basis uAxis, vAxis of the planar entity, where p, uAxis, and vAxis can be found by the function call plane.get(p, uAxis, vAxis).
Public method DistanceTo Retrieves the distance from this point to the specified point.
Public method DivideBy Returns a new point as the result of dividing this point's coordinates by the specified value. No actual coordinates of this point are changed.
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetAsVector Returns this point as a vector.
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method GetVectorTo Retrieves the vector with respect to the specified point.
Public method IsEqualTo(Point3d) Checks points for equality.
Public method IsEqualTo(Point3d, Tolerance) Checks points for equality with respect to the specified tolerance.
Public method Mirror Mirrors this point about the specified 3D plane.
Public method MultiplyBy Multiplies coordinates of this point by the passed value.
Public method OrthoProject Projects the 3D point with respect to the plane without a direction vector.
Public method Project Projects the 3D point with respect to the plane and direction vector.
Public method RotateBy Rotates this point about the specified vector by the specified angle.
Public method ScaleBy Scales this point by the scale factor about the specified point.
Public method Subtract Subtracts the specified value from each coordinate of this point and returns the resulting point.
Public method ToArray  
Public method ToString
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider)  
Public method ToString(String, IFormatProvider)  
Public method TransformBy  
Top
Operators
  Name Description
Public operatorStatic member Addition(Point3d, Vector3d) Addition operator for the Point3d class.
Public operatorStatic member Division(Point3d, Double) Division operator for the Point3d class.
Public operatorStatic member Equality(Point3d, Point3d) Equality operator for the Point3d class.
Public operatorStatic member Inequality(Point3d, Point3d) Inequality operator for the Point3d class.
Public operatorStatic member Multiply(Double, Point3d) Multiplication operator for the Point3d class.
Public operatorStatic member Multiply(Matrix3d, Point3d) Multiplication operator for the Point3d class.
Public operatorStatic member Multiply(Point3d, Double) Multiplication operator for the Point3d class.
Public operatorStatic member Subtraction(Point3d, Point3d) Subtraction operator for the Point3d class.
Public operatorStatic member Subtraction(Point3d, Vector3d) Subtraction operator for the Point3d class.
Top
See Also

©  Bricsys NV. All rights reserved.