TransientManagerGetFreeSubDrawingMode Method

Finds a free order for the specified drawable mode.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public int GetFreeSubDrawingMode(
        TransientDrawingMode mode,
        IntegerCollection viewportNumbers,
        ref int subDrawingMode
)

Parameters

mode  TransientDrawingMode
[in] Transient drawable mode.
viewportNumbers  IntegerCollection
[in] Collection of viewport indices.
subDrawingMode  Int32
[in] Draw order index.

Return Value

Int32
* 0 if the specified input draw order isn't free and the transient manager couldn't find a free draw order. * 1 if the specified input draw order is free. * 2 if the specified input draw order isn't free but the transient manager found a free draw order.
See Also

©  Bricsys NV. All rights reserved.