IntegerCollection Class

This class represents a collection of integer values.
Inheritance Hierarchy
SystemObject
  Teigha.GeometryIntegerCollection

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class IntegerCollection : IList

The IntegerCollection type exposes the following members.

Constructors
  Name Description
Public method IntegerCollection Default constructor for the IntegerCollection class. Creates an empty interger collection of 10 elements.
Public method IntegerCollection(Int32) Constructor for the IntegerCollection class. Creates an empty interger collection with the specified capacity.
Public method IntegerCollection(Int32) Copy constructor for the IntegerCollection class. Creates an interger collection based on the passed array of integers.
Top
Properties
  Name Description
Public property Capacity Represents the number of elements that this collection can contain.
Public property Count Represents the number of elements that this collection currently stores.
Public property IsFixedSize Property that indicates whether this collection has a fixed size.
Public property IsReadOnly Property that indicates whether this collection is read-only.
Public property IsSynchronized Property that indicates whether access to this collection is thread-safe.
Public property Item Property that represents an item from the collection at the specified index.
Public property SyncRoot Property that represents an object that can be used to synchronize access to this collection.
Top
Methods
  Name Description
Public method Add Adds a value to the end of this interger collection. This method grows the collection capacity if necessary.
Public method AddRange Adds a range of integer values to the end of this interger collection. This method grows the collection capacity if necessary.
Public method Clear Clears this interger collection.
Public method Contains Checks whether this interger collection contains the specified value.
Public method CopyTo Copies the specified array to this interger collection at the specified index.
Public method GetEnumerator Returns the enumerator for this integer collection.
Public method IndexOf Returns an index in the collection of the specified value.
Public method Insert Inserts the specified value to the collection at the provided index.
Public method Remove Removes the specified value from the collection.
Public method RemoveAt Removes a value from the collection at the specified index.
Public method ToArray Returns a handle to an array that represents this integer collection.
Public method TrimToSize Sets the capacity to the actual number of elements in this integer collection.
Top
Fields
  Name Description
Public fieldStatic member DefaultSize Size of the default integer collection.
Top
See Also

©  Bricsys NV. All rights reserved.