AssocDependencySetStatus Method

Sets the dependent-on-object of this dependency to be the specified compoundId parameter.

Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public void SetStatus(
        AssocStatus newStatus,
        bool notifyOwningNetwork
)

Parameters

newStatus  AssocStatus
[out] Database object on which this dependency should be dependent.
notifyOwningNetwork  Boolean
 
Remarks
Unlike the AttachToObject() method, this method does not add this dependency to the list of persistent reactors of the object. It is recommended to use the AttachToObject() method unless there is a specific reason to call this method.
See Also

©  Bricsys NV. All rights reserved.