Teigha.
|
Class | Description | |||||||||
---|---|---|---|---|---|---|---|---|---|---|
![]() |
AbstractViewPE | This class defines the interface of Protocol Extension classes for View, ViewTableRecord, Viewport and ViewportTableRecord objects. | ||||||||
![]() |
AbstractViewportData | This class is the base class of Protocol Extension classes for Viewport and ViewportTableRecord objects. | ||||||||
![]() |
AbstractViewTable | This is the base class for the two symbol table classes, ViewTable and ViewportTable. | ||||||||
![]() |
AbstractViewTableRecord | This class is the base class for ViewTableRecord and ViewportTableRecord. | ||||||||
![]() |
AlignedDimension | Wraps the OdDbAlignedDimension class. Represents aligned dimension entities. | ||||||||
![]() |
AnnotationScale | This class defines an annotation scale as a context object. | ||||||||
![]() |
Arc | This class implements a circular arc object (arc entity) in the database. This class inherits the base functionality of entities. An arc is a circular segment in world space. | ||||||||
![]() |
ArcDimension | Wraps the OdDbArcDimension class. Represents arc length dimension entities. | ||||||||
![]() |
Assoc2dConstraintCallback | This class implements the callback for the planar constraint group. Client code can register callback(s) derived from this class that are then called when events are triggered within the planar constraint group. | ||||||||
![]() |
Assoc2dConstraintGroup | This .NET class wraps the OdDbAssoc2dConstraintGroup class. The Assoc2dConstraintGroup class represents a set of geometric constraint relations between subentities of geometric entities. All the geometry entities must be coplanar. | ||||||||
![]() |
AssocAction |
This .NET class wraps the OdDbAssocAction class. Every object that needs to show associative behavior, i.e. when objects that rely on change are automatically evaluated by the associative mechanism, must be derived from an AssocActionBody class and owned by a parent AssocAction entity. The action body is owned by its parent action, for example when the parent action is deleted, it also erases the action body that is owned. The AssocAction class does not have virtual methods that can be overridden, therefore it should be done internally when there is no chance that objects of the derived action classes can become proxies. |
||||||||
![]() |
AssocArray | This .NET class wraps the OdDbAssocArrayActionBody class. It contains the identifier of the associative array and the identifier of the associative array's corresponding AcDbAssocArrayActionBody object that is used for evaluating the array's parameters. The stored AssocArrayParameters object manages parameters of the associative array. | ||||||||
![]() |
AssocArrayCommonParameters | This .NET class wraps the AcDbAssocArrayCommonParameters class. It provides an interface to control array parameters that are common to rectangular, path, and polar array parameters. | ||||||||
![]() |
AssocArrayParameters |
This .NET class wraps the AcDbAssocArrayParameters class. It provides an interface for managing array parameters. |
||||||||
![]() |
AssocArrayPathParameters | This .NET class wraps the OdDbAssocArrayPathParameters class. It provides an interface for managing array path parameters. | ||||||||
![]() |
AssocArrayPolarParameters |
This .NET class wraps the OdDbAssocArrayPolarParameters class. It provides an interface for managing polar array parameters. |
||||||||
![]() |
AssocArrayRectangularParameters |
This .NET class wraps the OdDbAssocArrayRectangularParameters class. It provides an interface for managing polar array parameters. |
||||||||
![]() |
AssocDependency |
This .NET class wraps the OdDbAssocDependency class. The AssocDependency class provides information about which associative actions (AssocActions instances) depend on or modify corresponding database objects. The associativity in drawings is represented exactly in this manner. Associative actions own dependencies which are then attached to the objects as persistent reactors. |
||||||||
![]() |
AssocEvaluationCallback |
This .NET class wraps the OdDbAssocEvaluationCallback class. This class implements a mechanism for associative actions (represented by the AssocActions class) to notify about the progress of evaluation, to report about the result of evaluation, notify about which objects will be used and modified by the action, to allow the evaluation programs to be terminated by the client, etc. |
||||||||
![]() |
AssocManager |
This .NET class wraps the OdDbAssocManager class. This class globally manages the associative framework. There is only one instance of the manager per database. |
||||||||
![]() |
AssocNetwork | This .NET class wraps the OdDbAssocNetwork class. This class keeps a network of associative actions (represented by the AssocActions class). | ||||||||
![]() |
AssocVariable | This class represents the variable which stores a scalar value of following types: * double; * int; * string; The value may be either a constant or be defined by an expression. The expression can refer to other symbols for which the evaluate() method of the variable can transform to the evaluated value using the current values of the referenced symbols. | ||||||||
![]() |
AssocVariableCallback | This class represents the associated callback. The client code can register callback(s) derived from associated callback that are then called when some events are triggered for variables. | ||||||||
![]() |
AttributeCollection | Provides a container for block reference attributes. | ||||||||
![]() |
AttributeDefinition | Wraps the OdDbAttributeDefinition class, which represents attribute defintion entities in an OdDbDatabase instance. | ||||||||
![]() |
AttributeReference | This class wraps the OdDbAttribute class which represents Attribute entities in an OdDbDatabase instance. | ||||||||
![]() |
AuditInfo | This class keeps track of common audit information to be used during a database audit operation. | ||||||||
![]() |
Background | This class is a base class for all background objects. Database-resident background objects are stored in the NamedObjectsDictionary under ACAD_BACKGROUND. | ||||||||
![]() |
BeginInsertEventArgs | This class represents data for the BeginInsert event of a database. | ||||||||
![]() |
BeginWblockBlockEventArgs | This class represents data for the BeginWblockBlock event of a database. | ||||||||
![]() |
BeginWblockEntireDatabaseEventArgs | This class represents data for the BeginWblockEntireDatabase event of a database. | ||||||||
![]() |
BeginWblockObjectsEventArgs | This class represents data for the BeginWblockObjects event of a database. | ||||||||
![]() |
BeginWblockSelectedObjectsEventArgs | This class represents data for the BeginWblockSelectedObjects event of a database. | ||||||||
![]() |
BlockBegin | This class represents BlockBegin entities in a database. BlockBegin entities are created and handled automatically for each BlockTableRecord object. Client applications may add extended data or extension dictionaries to these entities but should not create or delete them. These entities have no associated geometries. Do not derive from this class. | ||||||||
![]() |
BlockEnd | This class represents BlockEnd entities in a database. BlockEnd entities are created and handled automatically for each BlockTableRecord object. Client applications may add extended data or extension dictionaries to these entities but should not create or delete them. These entities have no associated geometries. Do not derive from this class. | ||||||||
![]() |
BlockInsertionPointsEventArgs | This class represents data for the BlockInsertionPoints event in a block table record. | ||||||||
![]() |
BlockPropertiesTable | |||||||||
![]() |
BlockPropertiesTableAuditError | |||||||||
![]() |
BlockPropertiesTableColumn | |||||||||
![]() |
BlockPropertiesTableColumnCollection | |||||||||
![]() |
BlockPropertiesTableRow | |||||||||
![]() |
BlockPropertiesTableRowCollection | |||||||||
![]() |
BlockReference | This class wraps the OdDbBlockReference class, which represents block references (inserts) in a database. | ||||||||
![]() |
BlockTable | Represents block definitions in a drawing database. | ||||||||
![]() |
BlockTableRecord | Wraps the OdDbBlockTableRecord class. BlockTableRecord objects represent containers for entities in a drawing file: all entities are owned by blocks which are stored in the block table as block table records. | ||||||||
![]() |
BlockTableRecordEnumerator | This class represents an enumerator to iterate through BlockTableRecord. | ||||||||
![]() |
Body | This class represents 3D body entities in a database. | ||||||||
![]() |
BulgeVertex | This class represents a bulge value at the 2D coordinates of a vertex. | ||||||||
![]() |
BulgeVertexCollection | This class represents a collection of BulgeVertex objects. | ||||||||
![]() |
Cell | This class represents table cells. | ||||||||
![]() |
CellBorder | This class represents a table cell border. | ||||||||
![]() |
CellBorders | This class represents table cell borders. | ||||||||
![]() |
CellContent | This class represents content of a table cell. | ||||||||
![]() |
CellContentsCollection | This class represents a collection of cell content objects for a cell. | ||||||||
![]() |
CellEnumerator | Represents an enumerator class for cells in BlockPropertiesTableRow. | ||||||||
![]() |
CellRange | This class represents a range of table cells. | ||||||||
![]() |
Circle | This class implements a circle object (Circle entity) in the database. This class inherits the base functionality of entities. A circle is a circular closed figure in world space. | ||||||||
![]() |
Column | This class represents a column of a cell range. | ||||||||
![]() |
ColumnsCollection | This class represents a collection of columns. | ||||||||
![]() |
CompoundObjectId | This class is used to identify an object in a database when the object is referenced via a path of BlockReferences. The object may reside in the host database, in an external reference database, or even in another unrelated database. | ||||||||
![]() |
ConstrainedGeometry | This class implements a constrained geometry node in the owning constraint group. This class is the base class for every type of geometry provided by constraint. | ||||||||
![]() |
ConstraintGroupNode | This class implements a node owned by a constraint group. This node is usually connected with a number of other nodes for which connection is not directed between any two nodes. | ||||||||
![]() |
Curve | This class is the base class for database-resident curves. | ||||||||
![]() |
Database | This .NET class wraps the OdDbDatabase class. The Database consists of various objects (header variables, symbol tables, table records, entities, and other objects) that represent a drawing file. | ||||||||
![]() |
DatabaseIOEventArgs | This class represents data for the database I/O-related events (BeginSave, DwgFileOpened and SaveComplete). | ||||||||
![]() |
DatabaseSummaryInfoBuilder | This class is required to build a DatabaseSummaryInfo object which stores a set of strings providing additional information about a .dwg file. | ||||||||
![]() |
DataCell | This class provides a way to represent the following data types in a generic manner: Boolean, integer, double, char*, Point3d, ObjectId, HardOwnershipId, SoftOwnershipId, HardPointerId, and SoftPointerId. | ||||||||
![]() |
DataCellCollection | This class represents a collection of DataCell objects. | ||||||||
![]() |
DataColumn | This class represents a column of a DataTable. | ||||||||
![]() |
DataLink | This class links a table to data in another file. | ||||||||
![]() |
DataLinkManager | This class manages the data links in a database. | ||||||||
![]() |
DataTable | This class provides general-purpose storage of simple numeric, character, 3D point, or object identifier information organized as a two-dimensional table. This class operates with two component classes: DataCell and DataColumn. | ||||||||
![]() |
DBDictionary | |||||||||
![]() |
DbDictionaryEnumerator | This class represents an enumerator for a collection of DBDictionaryEntry objects. | ||||||||
![]() |
DbHomeView | |||||||||
![]() |
DBObject | This class is the base class for all objects contained in a
Database instance. An object can be opened in any one of the
following modes:
|
||||||||
![]() |
DBObjectCollection | This class represents a collection of database objects. | ||||||||
![]() |
DBObjectReferenceCollection | This class represents a collection of database object references. | ||||||||
![]() |
DBPoint | This class implements a point object (point entity) in the database. This class inherits the base functionality of entities. | ||||||||
![]() |
DBText | This class represents single-line text entities in a database. | ||||||||
![]() |
DBVisualStyle | This class represents a visual style (a collection of properties) in a database. | ||||||||
![]() |
DgnDefinition | This class represents DGN underlay definitions. Underlays are similar to raster images, except the content of underlays can be snapped to. | ||||||||
![]() |
DgnReference | This class represents the DGN underlay references in the drawing. Underlays are similar to raster images, except the content of underlays can be snapped to. | ||||||||
![]() |
DgnUnderlayItem | This class represents DGN underlay items. | ||||||||
![]() |
DiametricDimension | Wraps the OdDbDiametricDimension class. Represents diametric dimension entities. | ||||||||
![]() |
DictionaryWithDefaultDictionary | This class introduces the concept of a 'default' entry for a dictionary. Each instance of this class has a HardPointerId data member that stores the object identifier of one of its entries. This hard pointer ID is the default entry. | ||||||||
![]() |
DimAssoc | This class is used to associate dimensions with geometry in a database. | ||||||||
![]() |
Dimension | |||||||||
![]() |
DimStyleTable | This class is the symbol table for DimStyleTableRecords that represents dimension styles within a drawing database. | ||||||||
![]() |
DimStyleTableRecord | This class represents records from the DimStyleTable. Each instance of this class contains the data necessary to generate a specific appearance for dimensions that reference it. This class has a number of properties that relate to the system variables for dimensions. For more information about system variables, see Working with System Variables and System Variables for .dwg files. | ||||||||
![]() |
DrawOrderTable | This .NET class wraps the OdDbSortentsTable class. Each instance of this class contains the DrawOrder for a single BlockRecord. When drawing entities in a Block Table Record, an iterator traverses the Block Table Record in the order of ascending handles. If there is a HandlePair in the DrawOrderTable corresponding to the handle of the object about to be drawn, the entity specified by the entity ID in the HandlePair is drawn instead. If there is no such HandlePair, the entity referenced by the iterator is drawn. | ||||||||
![]() |
DwfDefinition | This class represents DWF underlay definitions. Underlays are similar to raster images, except the content of underlays can be snapped to. | ||||||||
![]() |
DwfReference | This class represents the DWF underlay references in the drawing. Underlays are similar to raster images, except the content of underlays can be snapped to. | ||||||||
![]() |
DwgFiler | This class is the abstract base class for classes that are used for file I/O operations with the .dwg file format. | ||||||||
![]() |
DxfFiler | This class is the abstract base class for classes that are used for file I/O operations with the .dxf file format. | ||||||||
![]() |
DynamicBlockReferenceProperty | This class is a utility class referencing properties of dynamic blocks. | ||||||||
![]() |
DynamicBlockReferencePropertyCollection | This class represents a collection of DynamicBlockReferenceProperty objects. | ||||||||
![]() |
DynamicBlockReferencePropertyCollectionEnumerator | |||||||||
![]() |
DynamicDimensionChangedEventArgs | |||||||||
![]() |
DynamicDimensionData | This class represents dynamic dimensions which are temporary Dimension objects. These objects can be invoked and displayed when new database entities or grip-editing database-resident entities are created. | ||||||||
![]() |
DynamicDimensionDataCollection | This class represents a collection of DynamicDimensionData objects. | ||||||||
![]() |
EdgeRef |
This .NET class wraps the OdDbEdgeRef class. This class represents a reference to an edge. |
||||||||
![]() |
Ellipse | |||||||||
![]() |
Entity | This class is the base class for all graphical objects contained in a Database instance. | ||||||||
![]() |
ExplicitConstraint | This class implements a node owned by a constraint group. This node is usually connected with a number of other nodes for which connection is not directed between any two nodes. | ||||||||
![]() |
ExtrudedSurface | This class implements a three-dimensional extruded surface entity. | ||||||||
![]() |
Face | |||||||||
![]() |
FaceRecord | This class represents polyface mesh faces in a database. Each instance of this class stores the vertex indices of the vertices that are the face's corner points and the visibility information for the edges. | ||||||||
![]() |
FaceRef |
This .NET class wraps the OdDbFaceRef class. This class represents a reference to a face. |
||||||||
![]() |
FeatureControlFrame | This class represents feature control frames in an OdDbDatabase instance. | ||||||||
![]() |
Field | This class represents Field objects in a database. Field objects store the field expression and their evaluated values. Fields can be evaluated by an evaluator to any one of the following data types: Long, Double, String, Date, Point, 3dPoint, ObjectId, Buffer, and Resbuf. | ||||||||
![]() |
FieldCodeWithChildren | This class stores a field code and its embedded or nested (child) fields. | ||||||||
![]() |
FieldEngine | This class manages the evaluation of fields. | ||||||||
![]() |
FieldEvaluator | This class is an abstract base class that defines the field evaluator interface. | ||||||||
![]() |
FieldEvaluatorLoader | This class is used to load the evaluators required for evaluating fields. | ||||||||
![]() |
FieldResult | This class is used by the evaluators to set the evaluation status and evaluation result in the field. | ||||||||
![]() |
FieldResultImp | |||||||||
![]() |
FileDependencyManager | This class allows management of entries in the .dwg section of the File Dependency List. | ||||||||
![]() |
FormattedTableData | |||||||||
![]() |
GeoCoordinateCategory | |||||||||
![]() |
GeoCoordinateSystem | |||||||||
![]() |
GeoCoordinateTransformer | |||||||||
![]() |
GeoLocationData | |||||||||
![]() |
GeometricalConstraint | This class implements a constrained geometry node in the owning constraint group. It is the base class for all constraints. | ||||||||
![]() |
GeometryOverrule | |||||||||
![]() |
GeomRef |
This .NET class wraps the OdDbGeomRef class. This class represents a reference to geometry objects. |
||||||||
![]() |
GeoPositionMarker | This class represents a marker with label that is related to a geographical location. | ||||||||
![]() |
GradientBackground | |||||||||
![]() |
Graph | |||||||||
![]() |
GraphNode | |||||||||
![]() |
GraphNodeCollection | |||||||||
![]() |
GripData | This class describes grip data for entities. | ||||||||
![]() |
GripDataCollection | This class represents a collection of GripData objects. | ||||||||
![]() |
GripOverrule | This class overrules a subset of grip-linked operations that an entity specifies. It is used as a base class for classes derived from the Entity class to change their behavior. Each default implementation calls the corresponding method of the target class. | ||||||||
![]() |
GroundPlaneBackground | This class implements a ground plane for a background object in a viewport. | ||||||||
![]() |
Group | This class represents Group objects in a database instance. | ||||||||
![]() |
Hatch | Determines the geometry type used for hatch boundary edges. | ||||||||
![]() |
HatchLoop | This class stores information for defining a hatch boundary loop. | ||||||||
![]() |
Helix | This class represents helix entities in a database instance. | ||||||||
![]() |
HighlightOverrule | This class overrules a subset of highlight operations that an entity specifies. It is used as a base class for classes derived from the Entity class to change their behavior. Each default implementation calls the corresponding method of the target class. | ||||||||
![]() |
HostApplicationServices | This .NET class wraps the OdDbHostAppServices class. | ||||||||
![]() |
HyperLink | This class is the base class for HyperLink objects. HyperLink objects contain the following data: NameDescriptionHyperlink Name Filename or URL. Sublocation Named view, range of cells, etc. Description Display name for a hyperlink. | ||||||||
![]() |
HyperLinkCollection | This class represents a collection of HyperLink objects. | ||||||||
![]() |
IdMapping | This class is used in deep clone operations to map, using IdPair objects, object IDs from the original objects to their clones. | ||||||||
![]() |
IdMappingEventArgs | This class represents data for events that are related to ID mapping (BeginDeepClone, BeginDeepCloneTranslation, InsertMappingAvailable and WblockMappingAvailable) in a database. | ||||||||
![]() |
Image | This is the base class for raster-based entities, including RasterImage. | ||||||||
![]() |
ImageBackground | This class represents image-based backgrounds in a database. | ||||||||
![]() |
LayerStateDeletedEventArgs | |||||||||
![]() |
LayerStateEventArgs | |||||||||
![]() |
LayerStateManager | This class represents Layer State Manager objects. The LayerStateManager object can access and manage individual layer states associated with a database. | ||||||||
![]() |
LayerStateRenameEventArgs | |||||||||
![]() |
LayerTable | This class implements the layer table object, which represents a container for storing and accessing layer record objects in the database. This class inherits the base functionality of predefined tables. | ||||||||
![]() |
LayerTableRecord | This class implements the layer record object, which represents a layer in the database. This class inherits the base functionality of named records. | ||||||||
![]() |
LayerViewportProperties | This class defines properties of the layer viewports that are used in LayerTableRecord. | ||||||||
![]() |
Layout | This class represents Layout objects in a database. | ||||||||
![]() |
LayoutCopiedEventArgs | This class represents data for the LayoutCopied event in a layout manager. | ||||||||
![]() |
LayoutEventArgs | This class represents data for the layout-related events in a layout manager (AbortLayoutCopied, AbortLayoutRemoved, LayoutCreated, LayoutRemoved, LayoutSwitched, LayoutToBeCopied and XrefSubCommandAborted). | ||||||||
![]() |
LayoutManager | This class modifies and accesses Layout objects in a database. | ||||||||
![]() |
LayoutPaperPE | This class is the Protocol Extension class for OdDbLayout objects. The Protocol Extension class can be registered in the Layout class to provide a vectorization client the opportunity to customize the drawing of the background paper during PaperSpace vectorization. | ||||||||
![]() |
LayoutRenamedEventArgs | This class represents data for the layout renaming events in a layout manager (AbortLayoutRename, LayoutRenamed, LayoutCreated and LayoutToBeRenamed). | ||||||||
![]() |
Leader | This class represents leader entities in a database. This class contains a dynamic array of points that are used for the leader line. By default a leader is represented by straight line segments, however it is possible to set vertices to fit a spline. If the leader is associated with an annotation object, the last point of the leader resides near that annotation object. | ||||||||
![]() |
Light | This class represents a placeholder for all generic light properties that are stored in a database. | ||||||||
![]() |
Line | This class implements a line object (Line entity) in the database. This class inherits the base functionality of entities. A line is a straight segment in world space. | ||||||||
![]() |
LineAngularDimension2 | Wraps the OdDb2LineAngularDimension class. Represents two-line angular dimension entities. | ||||||||
![]() |
LinetypeTable | This class represents a container for storing and accessing the linetype record objects in a database. This class inherits the base functionality of predefined tables. | ||||||||
![]() |
LinetypeTableRecord | This class implements a linetype record object which represents a linetype in a database. This class inherits the base functionality of named records. | ||||||||
![]() |
LineWeightConverter | This class is used for converting lineweights. | ||||||||
![]() |
LinkedData | This class represents LinkedData objects in a database. | ||||||||
![]() |
LinkedTableData | This class represents LinkedTableData objects in a database. This enables linking to Excel data. | ||||||||
![]() |
LinkedTableEnumerator | |||||||||
![]() |
LoftedSurface | This class implements a three-dimensional lofted surface entity. | ||||||||
![]() |
LoftOptions | This class stores loft options used for creating lofted surfaces and lofted solids. Loft options are used to control the shape of the resulting surface or solid object. | ||||||||
![]() |
LoftOptionsBuilder | This class is used to build loft options. | ||||||||
![]() |
LoftOptionsCheckCurvesOut | This class encapsulates flags that represent states of cross-section curves when working with lofting operations. The flags indicate whether: * All of the cross-section curves are open. * All of the cross-section curves are closed. * All of the cross-section curves are planar. | ||||||||
![]() |
MatchProperties | This class is a base class for classes that copy properties between entities. | ||||||||
![]() |
Material | This class represents material properties for shaded entities. | ||||||||
![]() |
MentalRayRenderSettings | This class is a container class for the properties related to mental ray renderers. | ||||||||
![]() |
MInsertBlock | This class represents arrayed instances of block references (MInserts) in a database. | ||||||||
![]() |
MLeader | This class is the main class used for multileader (MLeader) objects. | ||||||||
![]() |
MLeaderStyle | This class represents MLeaderStyle objects in a database. | ||||||||
![]() |
Mline | This class represents multiline entities in a database. | ||||||||
![]() |
MlineStyle | This class represents multiline style objects in a database. | ||||||||
![]() |
MlineStyleElementCollection | This class represents a collection of BulgeVertex objects. | ||||||||
![]() |
MlineStyleElementCollectionEnumerator | This class represents an enumerator for a collection of MlineStyleElement objects. | ||||||||
![]() |
MPolygon | This class processes one or more closed polygons as a single polygon. | ||||||||
![]() |
MText | This class represents paragraph (multiline) text (MText) entities in a database. | ||||||||
![]() |
MTextFragment | This class describes a fragment of text created by the MText.explodeFragments() method. | ||||||||
![]() |
NurbSurface | This class represents non-uniform, rational B-Spline (NURBS) surfaces in a database. For more information, see Working with NURBS Surfaces. | ||||||||
![]() |
ObjectClosedEventArgs | This class represents data for the ObjectClosed event of a database. | ||||||||
![]() |
ObjectContext | This class represents a context that can determine what properties and behaviors are available for custom objects. | ||||||||
![]() |
ObjectContextCollection | This class represents a collection of objects that have context items defined. | ||||||||
![]() |
ObjectContextCollectionEnumerator | This class represents an enumerator for a collection of ObjectContext objects. | ||||||||
![]() |
ObjectContextManager | This class returns and manages the context objects that are available in a drawing. | ||||||||
![]() |
ObjectErasedEventArgs | This class represents data for the ObjectErased event of a database. | ||||||||
![]() |
ObjectEventArgs | This class represents data for different object-related events of a database. | ||||||||
![]() |
ObjectIdCollection | This class represents a collection of ObjectId objects. | ||||||||
![]() |
ObjectIdGraph | This class implements generic graph objects. | ||||||||
![]() |
ObjectIterator | This class defines bidirectional iterator objects that traverse entities contained in complex entities. | ||||||||
![]() |
ObjectOverrule | This class overrules a subset of operations that an object of a database specifies. It is used as a base class for classes derived from OdDbObject to change their behavior. Each default implementation calls the corresponding method of the target class. | ||||||||
![]() |
ObjectTypeAttribute | This class reports the type of an object. | ||||||||
![]() |
Ole2Frame | This class represents OLE2 entities in a database instance. This class provides a window that displays the OLE2 object. | ||||||||
![]() |
OpenCloseTransaction | This .NET class wraps the OdMgOpenCloseTransaction class. The OpenCloseTransaction class may be used instead of the Transaction class in certain scenarios. It wraps the ObjectId.Open/Close methods but makes it easier to correctly pair these methods by storing references to every object opened and automatically closing them. | ||||||||
![]() |
OpenModeAttribute | Reports the open mode. See the OpenMode documentation for more information. | ||||||||
![]() |
OrdinateDimension | Wraps the OdDbOrdinateDimension class. Represents ordinate dimension entities. An ordinate dimension entity dimensions the horizontal or vertical distance between the specified origin and the specified defining point. | ||||||||
![]() |
OsnapOverrule | This class overrules a subset of object snapping linked operations that an entity specifies. It is used as a base class for classes derived from an entity to change their behavior. Each default implementation calls the corresponding method of the target class. | ||||||||
![]() |
OsnapPointRef | |||||||||
![]() |
PdfDefinition | The class that implements PDF underlay definition functionality. | ||||||||
![]() |
PdfReference | The class that implements functionality for working with references to PDF content. | ||||||||
![]() |
PlaceHolder | This class implements Placeholder objects in an database instance. Placeholder objects are designed to be added to dictionaries, providing object identifiers that can be linked to dictionary keys. They are used in the Plot Style Name dictionary. | ||||||||
![]() |
PlaneSurface | This class implements a three-dimensional planar surface entity. | ||||||||
![]() |
PlotSettings | This class represents plot settings in a database instance. | ||||||||
![]() |
PlotSettingsValidator | This class defines access methods that validate data for plot settings prior to setting the data on the objects. | ||||||||
![]() |
PlotStyle | This class represents plot styles. | ||||||||
![]() |
PlotStyleTable | This class implements plot style tables. | ||||||||
![]() |
PlotStyleTableChangedEventArgs | This class represents data for the PlotStyleTableChanged event in a layout manager. | ||||||||
![]() |
Point3AngularDimension | Wraps the OdDb3PointAngularDimension class. Represents three-point angular dimension entities in a database. | ||||||||
![]() |
PointCloudCrop | This class represents cropping boundaries for point cloud entities. | ||||||||
![]() |
PointCloudEx | This class represents PointCloudEx entities in a database. These objects are drawable, selectable entities that place point cloud data in model or paper space, have their own transformation (position, orientation, scale) and other properties such as crop boundaries, scan and region visibilities, stylization types, color mapping schemes, etc. | ||||||||
![]() |
PointRef | This class defines a point reference between a dimension and its corresponding object. | ||||||||
![]() |
PolyFaceMesh | This class represents PolyFaceMesh entities in a database. A PolyFaceMesh entity consists of a list of PolyFaceMeshVertex (coordinate) vertices and a list of face records. Together they define a set of 3D faces. | ||||||||
![]() |
PolyFaceMeshVertex | This class represents PolyFaceMesh vertices in a database. | ||||||||
![]() |
PolygonMesh | This class represents PolygonMesh entities in a database. A PolygonMesh entity consists of a collection of PolygonMeshVertex (coordinate) vertices describing an M x N array of vertices, defining a set of 3D faces. M is the number vertices in a row, and N is the number of vertices in a column. The first N vertices define the first column, the second N defines the second column, etc. The mesh can be closed in the M and/or N directions. A closed mesh is connected from the last row or column to the first. | ||||||||
![]() |
PolygonMeshVertex | This class represents PolygonMesh vertices in a database. | ||||||||
![]() |
Polyline | This class represents lightweight polyline entities in a database instance. The difference between Polyline entities and Polyline2d entities: * Polyline entities are stored as single objects, thereby improving performance and reducing overhead compared to Polyline2d objects. * Curve fitting and spline fitting of Polyline entities are not supported. | ||||||||
![]() |
Polyline2d | This class represents 2D Polyline entities in a database. | ||||||||
![]() |
Polyline3d | This class represents 3D polyline entities in a database. | ||||||||
![]() |
PolylineVertex3d | This class represents vertices for a 3D polyline in a database. | ||||||||
![]() |
PropertiesOverrule | This class overrules a subset of property-linked operations that an object or entity specifies. It is used as a base class for classes derived from DBObject or DBEntity to change their behavior. Each default implementation calls the corresponding method of the target class. | ||||||||
![]() |
ProxyEntity | This is the base class for proxy entities derived from an entity in a database. | ||||||||
![]() |
ProxyObject | This class is the base class for proxy objects in a database. It provides an interface to the description data for the objects stored within proxy objects of a drawing. | ||||||||
![]() |
ProxyResurrectionCompletedEventArgs | This class provides data for the ProxyResurrectionCompleted event of the database. | ||||||||
![]() |
RadialDimension | Wraps the OdDbRadialDimension class. Represents radial dimension entities. | ||||||||
![]() |
RadialDimensionLarge | Wraps the OdDbRadialDimensionLarge class. Represents large (jogged) radial dimension entities. | ||||||||
![]() |
RasterImage | This class represents RasterImage entities in a database. | ||||||||
![]() |
RasterImageDef | This class defines raster image definition objects in a database. Raster image definitions work with raster image entities in a similar way that block table records work with block references. | ||||||||
![]() |
RasterVariables | This class represents RasterVariables objects in a database. | ||||||||
![]() |
Ray | This class implements the ray entity in a database. A ray is a semi-infinite line. | ||||||||
![]() |
RegAppTable | This class implements the RegAppTable that represents registered application names for extended entity data in a database. | ||||||||
![]() |
RegAppTableRecord | This class represents records in the RegAppTable of a database instance. | ||||||||
![]() |
Region | This class represents region entities in a database. | ||||||||
![]() |
RenderEnvironment | This is a container class for environment-related properties, such as fog and the global environment image. | ||||||||
![]() |
RenderGlobal | This class is a container for all global rendering properties. | ||||||||
![]() |
RenderSettings | This class is a container class for the properties relevant to generic high-fidelity renderers. | ||||||||
![]() |
ResultBuffer | This class implements the resulting buffer object that represents the structure for storing and passing the tagged data of all basic data types between various objects using different technologies. | ||||||||
![]() |
ResultBufferEnumerator | This class represents an enumerator to iterate through ResultBuffer. | ||||||||
![]() |
RevolvedSurface | This class implements a three-dimensional revolved surface entity. | ||||||||
![]() |
RevolveOptions | This class represents options for revolving. These options affect the shape of the revolved surface or revolved solid. | ||||||||
![]() |
RevolveOptionsBuilder | With this class you can modify the properties of the RevolveOptions class, which is an immutable value type. | ||||||||
![]() |
RevolveOptionsCheckRevolveCurveOut | This class contains indicators that show possible errors when checking if an entity can be revolved (with the RevolveOptions.CheckRevolveCurve method). | ||||||||
![]() |
RotatedDimension | Wraps the OdDbRotatedDimension class. Represents rotated dimension entities. | ||||||||
![]() |
Row | This class represents a row in a table of cells. | ||||||||
![]() |
RowsCollection | This class represents a collection of rows in a table. | ||||||||
![]() |
Section | This class represents a section plane. | ||||||||
![]() |
SectionManager | Represents a class that is used to manage the section planes in a database. | ||||||||
![]() |
SectionSettings | This class represents section plane settings. | ||||||||
![]() |
SecurityParameters | This class represents the security parameters used by a database. | ||||||||
![]() |
SequenceEnd | |||||||||
![]() |
Shape | This class represents Shape entities in a database. | ||||||||
![]() |
SkyBackground | This class implements a sky for a background object in a viewport. | ||||||||
![]() |
Solid | This class implements the two-dimensional, solid-filled object (planar solid entity) in a database. This class inherits the base functionality of entities. | ||||||||
![]() |
Solid3d | This class represents 3D solid entities in a database. This class inherits the base functionality of entities. | ||||||||
![]() |
SolidBackground | This class represents a solid background. | ||||||||
![]() |
Spline | This class represents spline entities in a database. | ||||||||
![]() |
SubDMesh | This class represents SubDMesh entities in a database. | ||||||||
![]() |
SubentityOverrule | This class overrules a subset of subentity linked operations that an entity specifies. It is used as a base class for classes derived from OdDbEntity to change their behavior. Each default implementation calls the corresponding method of the target class. | ||||||||
![]() |
SubentRef |
This .NET class wraps the OdDbSubentRef class. This class represents a reference to a sub-entity. |
||||||||
![]() |
Sun | This class stores properties related to a sun object. | ||||||||
![]() |
Surface | This class represents a 3D surface entity. | ||||||||
![]() |
SweepOptions | This class contains options used for creating swept surfaces and swept solids (by calling SweptSurface.createSweptSurface() or Solid3d.createSweptSolid() methods). Sweep options are used to control the shape of the resulting surface or solid object. | ||||||||
![]() |
SweepOptionsBuilder | This class is used for setting options used by the createSweptSurface() and createSweptSolid() methods. The options influence the shape of the created surface or solid. | ||||||||
![]() |
SweepOptionsCheckSweepCurveOut | This class stores options for checking sweep curves. | ||||||||
![]() |
SweptSurface | This class represents a swept surface entity. | ||||||||
![]() |
SymbolTable | This class implements a predefined table object, which represents a container for storing and accessing named record objects in the database. | ||||||||
![]() |
SymbolTableEnumerator | This class represents an enumerator for a symbol table. | ||||||||
![]() |
SymbolTableRecord | This class implements a named record object, which is the base class for all record objects in the database. | ||||||||
![]() |
SymbolUtilityServices | This .NET class contains various utilities for working with symbol names, symbol records, and symbol tables. | ||||||||
![]() |
SystemVariableChangedEventArgs | This class stores properties connected to system variable events (after the system variables are changed). | ||||||||
![]() |
SystemVariableChangingEventArgs | This class stores properties connected to system variable events (while the system variables are changing). | ||||||||
![]() |
Table | This class represents a table entity in a database. Table is a planar entity that can be created and placed in an arbitrary plane in 3D space. This entity is a rectangular array that stores annotation objects, primarily text. | ||||||||
![]() |
TableContent | This class represents table content in a database. This class derives from FormattedTableData and introduces formatting of a table with table style and cell styles. | ||||||||
![]() |
TableEnumerator | This class represents an enumerator for a table. | ||||||||
![]() |
TableStyle | This class represents table styles in a database. | ||||||||
![]() |
TableTemplate | This class stores and manages templates of tables. | ||||||||
![]() |
TextStyleTable | This class is a symbol table for TextStyleTableRecords and represents text styles. | ||||||||
![]() |
TextStyleTableRecord | This class implements a text style record object, which represents a text style in the database. This class inherits the base functionality of named records. | ||||||||
![]() |
Trace | This class implements a two-dimensional solid-filled object (trace entity) in the database. | ||||||||
![]() |
Transaction | This .NET class wraps the OdTransaction class. Transactions help to extend the limits of operations performed on an object and eliminate conflict errors. | ||||||||
![]() |
TransactionManager | This .NET class wraps the OdDbTransactionManager class. This class is used to manage transactions and provides additional functionality to manage the transaction-resident objects. | ||||||||
![]() |
TransformOverrule | This class overrules a subset of transformation-linked operations that an entity specifies. It is used as a base class for classes derived from the Entity class to change their behavior. Each default implementation calls the corresponding method of the target class. | ||||||||
![]() |
UcsTable | This class represents a UCS table object that is a container for storing and accessing UCS record objects in the database. The UCS is a user coordinate system. This class inherits the base functionality of predefined tables. | ||||||||
![]() |
UcsTableRecord | This class implements a UCS record object that represents a UCS in the database. The UCS is a user coordinate system. This class inherits the base functionality of named records. | ||||||||
![]() |
UnderlayDefinition | This class processes the linkage to external underlay content. Underlays are similar to raster images, except that users can snap to the content of an underlay. Instances of this class can be referenced by UnderlayReferences objects. UnderlayReferences objects are used to place the content that is linked by UnderlayDefinition. | ||||||||
![]() |
UnderlayFile | This class is implemented by host applications for support of underlays. | ||||||||
![]() |
UnderlayHost | This interface is implemented by host applications for support of underlays. This interface is used by the UnderlayDefinition and UnderlayReference objects to work correctly. | ||||||||
![]() |
UnderlayItem | This interface is implemented by host applications for support of underlays. This interface is used by the UnderlayDefinition and UnderlayReference objects to work correctly. | ||||||||
![]() |
UnderlayItemCollection | This class supplements a collection of UnderlayItem objects. | ||||||||
![]() |
UnderlayLayer | This class that represents underlay layers in a drawing. | ||||||||
![]() |
UnderlayLayerCollection | This class represents a collection of underlay layers. | ||||||||
![]() |
UnderlayReference | This class represents underlays in a drawing. Underlays are similar to raster images but their content can be snapped to. | ||||||||
![]() |
UnitsConverter | This class represents a units converter. | ||||||||
![]() |
UnitTypeAttribute | |||||||||
![]() |
Vertex | This class is the base class for all database vertices. | ||||||||
![]() |
Vertex2d | This class represents 2D polyline vertices in a database. | ||||||||
![]() |
VertexRef |
This .NET class wraps the OdDbVertexRef class. This class represents a reference to a vertex. |
||||||||
![]() |
Viewport | This class represents paperspace viewport entities in a database. | ||||||||
![]() |
ViewportTable | This class is the symbol table for ViewportTableRecords that represent viewport configurations when the system variable TILEMODE == 1. | ||||||||
![]() |
ViewportTableRecord | This class represents tiled viewport records in the ViewportTable of a database. | ||||||||
![]() |
ViewRepBlockReference | This .NET class wraps the OdDbViewRepBlockReference class which represents an entity used by model documentation views associated with a viewport. | ||||||||
![]() |
ViewTable | This class is the symbol table for ViewTableRecords that represent stored views within the drawing database. | ||||||||
![]() |
ViewTableRecord | This class represents view records in the ViewTable of a database. | ||||||||
![]() |
WblockNoticeEventArgs | This class represents data for the WblockNotice event of a database. | ||||||||
![]() |
Wipeout | This class represents wipeout entities in a database instance. | ||||||||
![]() |
Xline | This class represents an Xline object (infinite line entity) in a database. This class inherits the base functionality of entities. It is used as a construction line passed through a point. | ||||||||
![]() |
Xrecord | This class implements XRecord objects in a database. They are container objects that are used to attach arbitrary data to other database objects. | ||||||||
![]() |
XrefBeginOperationEventArgs | This class represents data for the XrefBeginOperation-related events (XrefBeginAttached, XrefBeginOtherAttached and XrefBeginRestore) in a database. | ||||||||
![]() |
XrefComandeeredEventArgs | This class represents data for the XrefComandeered event in a database. | ||||||||
![]() |
XrefFullSubentityPath | This class uniquely defines external reference subentities within a database. Each instance of this class consists of a SubentId object, an ordered array of object identifiers, and an ordered array of entity handles. The SubentId consists of the index and subentType of the object. The array of object IDs and the array of handles define the path to the subentity from the outermost entity (in paper space or model space) to the entity containing the subentity. | ||||||||
![]() |
XrefGraph | This class represents the external reference tree of a database. This class uses XrefGraphNode objects to represent an xref database at each node. | ||||||||
![]() |
XrefGraphNode | This class represents an xref database. An XrefGraph object represents the relationship between a host drawing, its externally referenced drawings, and any nested xref drawings. Within a graph, any database or xref BlockTableRecord is represented by the XrefGraphNode class. Relationships between databases are represented by an edge in the graph. These relationships can be input (databases that are referencing this node) and output (databases that are referenced by this node). The relationships can be obtained using the GraphNode.in(idx) and GraphNode.out(idx) calls. | ||||||||
![]() |
XrefPreXrefLockFileEventArgs | This class represents data for the XrefPreXrefLockFile event in a database. | ||||||||
![]() |
XrefRedirectedEventArgs | This class represents data for the XrefRedirected event in a database. | ||||||||
![]() |
XrefSubCommandEventArgs | This class represents data for events that are related to the external reference subcommands (XrefSubCommandStart, XrefSubCommandEnd and XrefSubCommandAborted) in a database. | ||||||||
![]() |
XrefVetoableSubCommandEventArgs |
Structure | Description | |
---|---|---|
![]() |
AdsName | |
![]() |
CellReference | This structure represents a currently referenced cell. |
![]() |
CustomScale | This class stores the numerator and denominator values that compose a custom print scale. |
![]() |
DatabaseSummaryInfo | This class stores a set of strings providing additional information about a .dwg file. This class supports using your own custom fields that are stored in a list with custom field names and corresponding values. |
![]() |
DataTypeParameter | Represents a data type parameter. |
![]() |
DBDictionaryEntry | This class represents an entry in a DatabaseServices.DBDictionary object. It contains the key and object ID of an entry but does not store an actual entry. |
![]() |
DBObjectReference | This class stores an object's ID and the code of the DXF that represents the object's type. |
![]() |
DecomposeForSaveReplacementRecord | This class stores the three output parameters used by the Object.decomposeForSave() method. These values relate to the replacement object if it is not a database-resident, the replacement object's identifier if it is a database-resident, and an option indicating whether XData is passed to the replacement object. |
![]() |
Extents2d | This class represents 2D bounding boxes as minimum and maximum 2D points for various graphical objects. |
![]() |
Extents3d | This class represents 3D bounding boxes as minimum and maximum 3D points for various graphical objects. |
![]() |
FieldEvaluationResult | |
![]() |
FieldEvaluationStatusResult | This class stores the codes that represent the results of a field evaluation. |
![]() |
FieldUpdateResult | This class stores results of evaluating fields. |
![]() |
FileDependencyInfo | This class represents entries in the .dwg section of the File Dependency List. |
![]() |
FitData | |
![]() |
FullDwgVersion | |
![]() |
FullSubentityPath | This class uniquely defines subentities within in a database. Each instance of this class consists of a SubentId object and an ordered array of Object IDs. The SubentId consists the index and subentType of the object. The array of Object IDs defines the path to the entity containing the specified subentity from the outermost entity (in PaperSpace or ModelSpace). |
![]() |
GeoDatum | |
![]() |
GeoEllipsoid | |
![]() |
GeoProjectionParam | |
![]() |
GradientColor | |
![]() |
GridPropertyParameter | This structure stores grid line properties for table entities. |
![]() |
Handle | This class encapsulates the 64-bit integer handles associated with DBObject instances. Handles are persistent and unique within a database. Handles are not, however, unique between databases. |
![]() |
IdPair | This class is the element class for IdMapping, which is used in deepclone operations to map object IDs from the original objects to their clones. Key is the object ID of the original object. Value is the object ID of the cloned object. |
![]() |
ItemLocator | ItemLocator structure represents index{i, j, k} of an item in a rectangular array. |
![]() |
MeshDataCollection | This structure stores data returned by the SubDMesh.GetObjectMesh method. |
![]() |
MeshFaceterData | This structure stores data used by the SubDMesh.GetObjectMesh method. |
![]() |
MeshPointMap | This structure stores data returned by the GeoLocationData.GetMeshPointMap method. |
![]() |
MeshPointMaps | This structure stores data returned by the GeoLocationData.GetMeshPointMaps method. |
![]() |
MlineStyleElement | This class stores information about color, offset, and linetype ID values used for MlineStyle objects. |
![]() |
NurbsData | Replaces any existing spline data with the data provided in this object. |
![]() |
ObjectId | This class implements memory-resident ObjectId objects for database objects. |
![]() |
PatternDefinition | This class encapsulates the data returned by the Hatch.getPatternDefinitionAt() function. |
![]() |
PlotStyleData | |
![]() |
PlotStyleDescriptor | This class encapsulates a PlotStyleNameType enum value and the object ID of the associated plot style name dictionary entry. |
![]() |
Rectangle3d | This class stores points that define a 3D rectangle. |
![]() |
RegionAreaProperties | This class stores data that is used for the AreaProperties property of a region. |
![]() |
RenderEnvironmentDoubleRangeParameter | This class stores information about the near and far distances of fog. |
![]() |
RenderGlobalDimensionsParameter | This structure contains information about the height and width parameters of the RenderGlobal.Dimensions property. |
![]() |
RenderGlobalProcedureAndDestinationParameter | This structure contains information about the procedure and destination parameters for the RenderGlobal.ProcedureAndDestination property. |
![]() |
SectionHitTestInfo | |
![]() |
Solid3dMassProperties | This structure represents mass properties of a 3D solid. This instance is used together with 3dSolid.getMassProp(). |
![]() |
SubentityId | This class implements subentity ID objects for entity objects in a database. An entity object can consist of any number of graphical subentities. Subentity type must be one of the following: NameValueNull 0 Face 1 Edge 2 Vertex 3 MlineCache 4 Class 5 Each SubentityId object is created from a Subentity type and an index. |
![]() |
SurfaceSliceResults | This struct contains data that is used in the Surface.SliceByPlane and Surface.SliceBySurface methods. |
![]() |
TableHitTestInfo | Class data that is received from the Table.hitTest() method. |
![]() |
TypedValue | This value type may contain objects of various types. The TypeCode property defines the type of the value. Instances of this class are used as tagged data in resulting buffers to provide a pair: code - value. |
Interface | Description | |
---|---|---|
![]() |
IParameter | |
![]() |
ISubObject |
Enumeration | Description | |
---|---|---|
![]() |
AngleConstraint | This enum class represents the segment angle type of a multileader. |
![]() |
AnnotationType | The type of annotation used by a leader entity. |
![]() |
AnnotativeStates | This enum class determines the state of the annotation (whether it exists or not). |
![]() |
ApplicationLoadReasons | The enumeration that contains reasons to load an application. |
![]() |
AssocArrayPathParametersMethodType | Represents methods for how objects are arrayed along a path. |
![]() |
AssocArrayPolarParametersArcDirection | Represents the direction of the arc on which the array elements depend. |
![]() |
AssocDraggingState | During the evaluation, the action may request information from the client code about whether evaluation is happening inside of the dragging loop and information about the state of the dragging. |
![]() |
AssocEvaluationMode | In some cases, custom code needs to query the mode in which it should evaluate itself. |
![]() |
AssocEvaluationPriority | Represents the evaluation priority. |
![]() |
AssocFlags | Determines which point reference object is used. |
![]() |
AssocStatus | Represents the associative status. |
![]() |
AssocTransformationType | Information about what kind of transformation was made with the entities before evaluating the actions that have dependencies on those entities. |
![]() |
AttachmentPoint | Represents the attachment point of an MText object. |
![]() |
AuditPass | Represents a pass of the audit command. |
![]() |
BitmapDeviceFlags | The enumeration that contains flags for bitmap devices. |
![]() |
BlockConnectionType | This enum class represents the block connection type of MLeader block content. |
![]() |
BlockPropertiesTableAuditErrorType | This enumeration class represents the audit error types for a block properties table. |
![]() |
BlockScaling | Represents a block scale type for block references associated with a block table record. |
![]() |
BooleanOperationType | This enum class represents types of Boolean operations. |
![]() |
CellAlignment | This enum struct specifies how text is aligned in a table cell. These values are relevant when text is oriented horizontally. |
![]() |
CellClass | This enum class represents cell class types. |
![]() |
CellContentLayout | This enum class represents options related to layout of cell content. |
![]() |
CellContentTypes | This enum class represents cell content types. |
![]() |
CellEdgeMasks | This enum class represents cell edge of a cell. |
![]() |
CellMargins | This enum class represents cell margin types. |
![]() |
CellOption | This enum class represents cell options for some operations. |
![]() |
CellProperties | This enum class represents cell properties. |
![]() |
CellStates | This enum class represents cell states. |
![]() |
CellType | Represents data types that can be stored by the DataCell object. |
![]() |
ClipBoundaryType | Clip boundary types for raster images. |
![]() |
CollisionType | Specifies how the entity interacts with collision detection. |
![]() |
ColumnType | |
![]() |
ConstrainType | Represents helix constraint types. |
![]() |
ContentType | This enum class represents the content type of an MLeader. |
![]() |
DataLinkGetSourceContext | Represents the source context of a data link. |
![]() |
DataLinkOption | Represents data link options. |
![]() |
DataType | |
![]() |
DeepCloneType | Deep clone types. |
![]() |
DefaultLightingType | Represents a default lighting type. |
![]() |
DimArrowFlag | |
![]() |
DimAssocPointType | Represents the type of point association. |
![]() |
DimensionCenterMarkType | Defines the type of dimension center mark. |
![]() |
DragStatus | Specifies drag states. |
![]() |
DrawLeaderOrderType | This enum class represents line draw order types of a multileader. |
![]() |
DrawMLeaderOrderType | This enum class represents the draw order types of a multileader. |
![]() |
DuplicateRecordCloning | Determines what actions are performed if symbols or dictionary entries are cloned and a duplicate is found in the destination database. |
![]() |
DwgVersion | Wraps the OdDb::DwgVersion enum. Defines values for respective versions of .dwg file format. |
![]() |
DxfCode | |
![]() |
DynamicBlockReferencePropertyUnitsType | Represents the units of the property. |
![]() |
EdgeExtensionType | |
![]() |
EndCap | Describes the possible types of an endcap. |
![]() |
EntityVisualStyleType | |
![]() |
EraseFlags | Represents flags for erasing empty objects. |
![]() |
EvalFields | |
![]() |
ExposureType | Represents the available exposure types. |
![]() |
FieldCodeFlags | Represents field code flags. |
![]() |
FieldEvaluationContext | This .NET enumeration wraps the OdDbField::EvalContext enumeration. These values specify the context in which the field is evaluated. |
![]() |
FieldEvaluationOptions | Represents evaluation options for the field. |
![]() |
FieldEvaluationStatus | These values specify the evaluation status of the field. |
![]() |
FieldFilingOptions | Specifies the filing options set by the field evaluators. |
![]() |
FieldState | Represents the state of the field. |
![]() |
FileOpenMode | This enumeration provides the mode values used to specify how a database resident object is to be opened. |
![]() |
FilerType | Represents the types of filers. |
![]() |
FillStyle | |
![]() |
FindFileHint | This .NET class wraps the OdDbHostAppServices::FindFileHint enumeration. |
![]() |
FlowDirection | This enum represents flow direction of the multiline text. |
![]() |
FormatOption | This enum class represents format options for values. |
![]() |
FrameSetting | Represents the current image frame visibility setting. |
![]() |
GeoCSProjectionCode | |
![]() |
GeoCSType | |
![]() |
GeoCSUnit | |
![]() |
GeometricalConstraintConstraintType | Indicate the new constraint type when it is added between geometries. |
![]() |
GetGripPointsFlags | Represents get-grip point flags. |
![]() |
GlyphDisplayType | Glyph display types. |
![]() |
GradientPatternType | Determines the source of the gradient pattern. |
![]() |
GraphicsMetafileType | Indicates data that is in the proxy's graphics metafile (if it exists). |
![]() |
GridLineStyle | This enum class represents a grid line style. |
![]() |
GridLineType | This enum class represents grid linetypes. |
![]() |
GridProperties | This enum class represents grid properties. |
![]() |
GripDataContext | This enumeration specifies grip context flags. |
![]() |
GripDataDrawType | This enumeration specifies grip draw types. |
![]() |
GripDataReturnValue | Represents the results of operation execution. |
![]() |
GripDataStatus | This enumeration specifies grip status types. |
![]() |
GripStatus | Specifies grip states. |
![]() |
GsMarkType | Represents multileader GS mark types. |
![]() |
HatchEdgeType | Determines the geometry type used for hatch boundary edges. |
![]() |
HatchLoopTypes | Determines types of hatch loops. |
![]() |
HatchObjectType | Determines the hatch object type. |
![]() |
HatchPatternType | Determines the hatch pattern type. |
![]() |
HatchStyle | Determines hatch style values. |
![]() |
ImageDisplayOptions | Display options for raster images. |
![]() |
ImageOrg | Represents the pixel organization scheme of the source image file. |
![]() |
ImageQuality | Represents the display quality of the image. |
![]() |
IndexCreation | This enum relates to the INDEXCTL header variable. INDEXCTL specifies the creation of layer and spatial indices in the database. |
![]() |
Intersect | Specifies which actions are performed to calculate intersections between entities. |
![]() |
JoinStyle | Describes possible values of lineweight endcaps for new entities. |
![]() |
LampColorPreset | Lamp color presets. |
![]() |
LampColorType | Lamp color type. |
![]() |
LayerEvaluation | This enum relates to the LAYEREVAL header variable. LAYEREVAL controls when the list of unresolved layers is checked for analysis. |
![]() |
LayerStateMasks | Enumeration that determines which layer attributes are to be stored in the layer state. |
![]() |
LeaderDirectionType | This enum class represents the direction type of an MLeader. |
![]() |
LeaderType | This enum class represents the leader type of a multileader. |
![]() |
LightingUnits | Specifies the lighting units for the drawing. |
![]() |
LineEndStyle | |
![]() |
LineJoinStyle | |
![]() |
LineSpacingStyle | |
![]() |
LineType | |
![]() |
LineWeight | Represents lineweights in 100ths of a millimeter, except special negative values that indicate that the lineweight is either set by owner block, set by owner layer, or defined by the LWDEFAULT system variable. |
![]() |
LoftOptionsNormalOption | This enumeration specifies plane normal lofting options. |
![]() |
LoopDirection | Declares the loop directions. |
![]() |
MaintenanceReleaseVersion | |
![]() |
MeasurementValue | Represents measurement systems. |
![]() |
MergeCellStyleOption | Specifies options for merging cell styles. |
![]() |
MlineJustification | This enum represents justification types of a multiline object. |
![]() |
ModelerFlavor | The enumeration that contains possible levels of geometric modeler support available from the host applications. |
![]() |
MoveGripPointsFlags | Represents move-grip point flags. |
![]() |
MoveType | Represents multileader move types. |
![]() |
MTextFragmentCallbackStatus | This enum represents the returned result of the MTextFragmentCallback callback function. |
![]() |
NewLayerNotification | This enum relates to the LAYERNOTIFY header variable. |
![]() |
ObjectSnapModes | Represents object snap modes. |
![]() |
Ole2FrameItemType | Defines the item type in the frame. |
![]() |
OleDvAspect | |
![]() |
OpenMode | Mode in which to open a database object. |
![]() |
OrthographicView | Represents orthographic views. |
![]() |
PaperOrientationStates | This enum class represents the state of the paper orientation of an annotative object. |
![]() |
ParseOption | This enum class represents parsing options for values. |
![]() |
PasswordOptions | This .NET class wraps the OdDbHostAppServices::PasswordOptions enumeration. |
![]() |
PathOption | Represents storage options for paths. |
![]() |
PhysicalIntensityMethod | Physical intensity methods. |
![]() |
Planarity | Specifies the planarity of geometry. |
![]() |
PlotPaperUnit | This enumerated type represents the units used for plotting. |
![]() |
PlotRotation | This enumerated type describes how the camera is rotated for the plot. |
![]() |
PlotSettingsShadePlotType | This enumerated type represents the shade plot mode of the current PlotSettings object. |
![]() |
PlotStyleNameType | This enum class represents types of a plot style name. |
![]() |
PlotType | This enumerated type represents plot style settings. |
![]() |
PointCloudCropType | This enumeration represents point cloud crop types which are the shapes of the crop region. |
![]() |
PointCloudDispOptionOutOfRange | This enumeration represents various types of behavior when an option (intensity of elevation) is out of range. |
![]() |
PointCloudProperty | This enumeration defines the types of properties available for a point cloud. |
![]() |
PointCloudPropertyState | This enumeration defines the property state indicators. |
![]() |
PointCloudStylizationType | This enumeration represents various stylization types for point cloud entities. |
![]() |
Poly2dType | Represents the types of 2D polylines. |
![]() |
Poly3dType | Represents the types of 3D polylines. |
![]() |
PolyMeshType | Represents polymesh types. |
![]() |
RenderGlobalDestination | This enum class represents available output destinations for rendering. |
![]() |
RenderGlobalProcedure | |
![]() |
RenderMode | This enum class represents render modes for the view. |
![]() |
RotatedDimType | Represents the type of rotated dimension alignment. |
![]() |
RotationAngle | This enum class represents text rotation inside table cells. |
![]() |
RowType | This enum class specifies how text is aligned in a table cell. These values are relevant when text is oriented horizontally. |
![]() |
SaveType | Type of the saved file. |
![]() |
ScaleEstimationMethod | Represents the scale estimation method. |
![]() |
SectionGeneration | Represents the generation properties for section generation. |
![]() |
SectionGeometry | Represents geometry properties for section generation. |
![]() |
SectionHeight | Represents the height states for the section plane. |
![]() |
SectionState | Represents the section plane type. |
![]() |
SectionSubItem | Represents the subitems for the section plane. |
![]() |
SectionType | Represents the section types for section generation. |
![]() |
SecurityActions | Represents security actions that can be performed. |
![]() |
SecurityAlgorithm | Represents security algorithms. |
![]() |
SegmentType | Represents the segment type of the polyline. |
![]() |
SelectType | Represents selection types. |
![]() |
ShadePlotResLevel | This enumerated type represents the shade plot resolution level. |
![]() |
ShadePlotType | This enum class represents the available shaded plot types for a viewport. |
![]() |
ShadowSamplingMultiplier | This enumeration represents a shadow sampling multiplier for area lights. |
![]() |
StandardScaleType | This enum class represents the standard print scale selection for the plot settings. |
![]() |
StdScaleType | This enumerated type represents the "standard" print scale selection, including scale-to-fit, for the plot settings object. |
![]() |
SubentityType | Specifies subentity types for objects of the DBSubentId class. |
![]() |
SweepOptionsAlignOption | Represents the alignment options enumerator for swept entities. |
![]() |
TableBreakFlowDirection | This enum class represents table breaking flow direction options. |
![]() |
TableBreakOptions | This enum class represents table break options. |
![]() |
TableCellType | This enum class specifies the cell type. |
![]() |
TableCopyOptions | This enum class represents the table copy options. |
![]() |
TableEnumeratorOption | This enum class represents the table iterator options. |
![]() |
TableFillOptions | This enum class specifies table fill options. |
![]() |
TableHitTestType | This enum class represents the type of a hit test to perform for a table. |
![]() |
TableStyleFlags | This enum class represents flags that are used for working with table styles. For internal use. |
![]() |
TableStyleOverride | This enum class specifies how text is aligned in a table cell. These values are relevant when text is oriented horizontally. |
![]() |
TextAlignment | This enumeration represents alignments of text. |
![]() |
TextAlignmentType | This enum class represents the text alignment type of a multileader. |
![]() |
TextAngleType | This enum class represents the text angle type of multileader text. |
![]() |
TextAttachmentDirection | This enum class represents the text attachment direction of multileader text. |
![]() |
TextAttachmentType | This enum class represents the text attachment type of multileader text (MLeader). |
![]() |
TextHorizontalMode | |
![]() |
TextVerticalMode | |
![]() |
TimeZone | Represents various time zones. |
![]() |
TypeOfCoordinates | Represents the type of design coordinates. |
![]() |
UnderlayLayerState | This enum class represents the state of an underlay layer. |
![]() |
Unit | Represents measurement units. |
![]() |
UnitsValue | Specifies unit values. |
![]() |
UnitType | Represents unit types for various properties and operations. |
![]() |
UpdateAction | |
![]() |
UpdateDirection | This enum class represents update directions for data links. |
![]() |
UpdateOption | This enum class represents update options for data links. |
![]() |
Vertex2dType | This enum class represents various 2D vertex types. |
![]() |
Vertex3dType | Specifies vertex types. |
![]() |
ViewTableRecordRenderMode | Represents viewport table record render modes. |
![]() |
Visibility | This enum class represents visibility statuses of a grid line. |
![]() |
XrefNotificationStatus | This enum class represents the status for xref resolution notifications. |
![]() |
XrefOperation | Represents the external reference subcommands. |
![]() |
XrefStatus | This enum class represents the xref status of a node. |