Checks objects for equality.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public override sealed bool Equals(
Object other
)
Public Overrides NotOverridable Function Equals (
other As Object
) As Boolean
public:
virtual bool Equals(
Object^ other
) override sealed
abstract Equals :
other : Object -> bool
override Equals :
other : Object -> bool
Parameters
- other Object
- [in] Object to check for equality.
Return Value
Boolean
Remarks
For Equals and GetHashCode
methods, an override should be completed together to match logic;
if Equals returns true, hashcodes should be the same; the same
hashcodes do not always mean that the objects are the same because
of collisions; hashcodes should be formed on fields on which
equality is based; sometimes the Equals
method is taken from a C++ object, but since pointers are compared,
you still can use GetHashCode of a
disposable wrapper, while Equals can be
overridden in a derived class.
See Also