Scale2dExtractScale
Method
|
Returns the scale that corresponds to the
length of the column vectors of the specified transformation
matrix.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static Scale2d ExtractScale(
Matrix2d mat
)
Public Shared Function ExtractScale (
mat As Matrix2d
) As Scale2d
public:
static Scale2d ExtractScale(
Matrix2d mat
)
static member ExtractScale :
mat : Matrix2d -> Scale2d
Parameters
- mat Matrix2d
- [in] 2D transformation matrix from which to retrieve the
scale.
Return Value
Scale2d
See Also