Scale2d Structure

This structure represents scaling transformations (scale vectors) in 2D space. The Scale2d may be viewed as an array[2] of doubles. Array indicies: * 0 - Scale factor for the x-axis. * 1 - Scale factor for the y-axis.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryScale2d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct Scale2d

The Scale2d type exposes the following members.

Constructors
  Name Description
Public method Scale2d(Double) Constructor for the Scale2d class. Creates a scale transformation with the specified uniform scale factor.
Public method Scale2d(Double) Constructor for the Scale2d class. Creates a scale transformation with the specified factors for x- and y-axes.
Public method Scale2d(Double, Double) Constructor for the Scale2d class. Creates a scale transformation with the specified factors for x- and y-axes.
Top
Properties
  Name Description
Public property Coordinate Property that represents a scale factor at the specified index.
Public property X Property that represents a scale factor for the x-axis.
Public property Y Property that represents a scale factor for the y-axis.
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public methodStatic member ExtractScale Returns the scale that corresponds to the length of the column vectors of the specified transformation matrix.
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method GetMatrix Returns the transformation matrix equivalent to this scale vector.
Public method Inverse Returns the inverse of this scale vector.
Public method IsEqualTo(Scale2d) Checks whether the specified scale vector equals this scale vector.
Public method IsEqualTo(Scale2d, Tolerance)  
Public method IsProportional Checks whether this scale vector scales uniformly.
Public method IsProportional(Tolerance)  
Public method MultiplyBy  
Public method PostMultiplyBy Sets this scale vector to the product (this scale vector) * (rightSide), and returns the resulting vector.
Public method PreMultiplyBy Sets this scale vector to the product (rightSide) * (this scale vector), and returns the resulting vector.
Public methodStatic member RemoveScale Returns the scale vector corresponding to the length of the column vectors of the transformation matrix, and sets the scale factor of the matrix to 1.
Public method ToArray Returns an array of two values that represent the scale factors for x-and y-axes.
Public method ToString Returns a string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns a string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(Scale2d, Scale2d) Equality operator for the Scale2d class.
Public operatorStatic member Inequality(Scale2d, Scale2d) Inequality operator for the Scale2d class.
Public operatorStatic member Multiply(Double, Scale2d) Multiplication operator for the Scale2d class. Multiplies a scale factor by the specified scale vector and returns the resulting vector.
Public operatorStatic member Multiply(Scale2d, Double) Multiplication operator for the Scale2d class. Multiplies a scale vector by the specified scale factor and returns the resulting vector.
Public operatorStatic member Multiply(Scale2d, Scale2d) Multiplication operator for the Scale2d class. Multiplies the left scale vector by the right scale vector (a*b) and returns the resulting vector.
Top
See Also

©  Bricsys NV. All rights reserved.