GIRasterImageConvert(Boolean,
Double, Double, Double, Color, Boolean, Boolean, Boolean,
GIRasterImage) Method
|
Converts this raster image according to the
specified parameters and returns a handle to the converted
image.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public GIRasterImage Convert(
bool convertPaletteToRGB,
double brightness,
double contrast,
double fade,
Color backgroundColor,
bool flipX,
bool flipY,
bool rotate90,
GIRasterImage image
)
Public Function Convert (
convertPaletteToRGB As Boolean,
brightness As Double,
contrast As Double,
fade As Double,
backgroundColor As Color,
flipX As Boolean,
flipY As Boolean,
rotate90 As Boolean,
image As GIRasterImage
) As GIRasterImage
public:
GIRasterImage^ Convert(
bool convertPaletteToRGB,
double brightness,
double contrast,
double fade,
Color backgroundColor,
bool flipX,
bool flipY,
bool rotate90,
GIRasterImage^ image
)
member Convert :
convertPaletteToRGB : bool *
brightness : float *
contrast : float *
fade : float *
backgroundColor : Color *
flipX : bool *
flipY : bool *
rotate90 : bool *
image : GIRasterImage -> GIRasterImage
Parameters
- convertPaletteToRGB Boolean
- [in] Color is converted to RGB if true.
- brightness Double
- [in] Image brightness [0 .. 100].
- contrast Double
- [in] Image contrast [0 .. 100].
- fade Double
- [in] Image fade value [0 .. 100].
- backgroundColor Color
- [in] Background color.
- flipX Boolean
- [in] Image is flipped about the x-axis if true.
- flipY Boolean
- [in] Image is flipped about the y-axis if true.
- rotate90 Boolean
- [in] Image is rotated 90° if true.
- image GIRasterImage
- [in] Image that stores image parameters (width, height, pixel
format, color depth, etc.) to which this image should be
converted.
Return Value
GIRasterImage
See Also