SubDMeshSetCone Method

Creates a mesh of a cone.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public void SetCone(
        double majorRadius,
        double minorRadius,
        double height,
        int divAxis,
        int divHeight,
        int divCap,
        double radiusRatio,
        int smoothLevel
)

Parameters

majorRadius  Double
[in] Major radius.
minorRadius  Double
[in] Minor radius.
height  Double
[in] Height of a cone.
divAxis  Int32
[in] Specifies how many divisions are made for the base circle.
divHeight  Int32
[in] Specifies how many divisions are made in the direction of the height of a cone.
divCap  Int32
[in] Specifies how many radial divisions are made for the base circle.
radiusRatio  Double
[in] Ratio of top to bottom radii.
smoothLevel  Int32
[in] Level of smoothness.
See Also

©  Bricsys NV. All rights reserved.