NurbCurve3dDataInequality Operator

Inequality operator for the NurbCurve3dData structure. Checks whether curve data is not equal.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public static bool operator !=(
        NurbCurve3dData a,
        NurbCurve3dData b
)

Parameters

a  NurbCurve3dData
[in] Left curve data to compare.
b  NurbCurve3dData
[in] Right curve data to compare.

Return Value

Boolean
true if at least one of the following conditions fails: * both curves are rational (weight values applied) or not rational (weight values are not applied) * both curves are periodic (closed) or not periodic (open) * control points are equal * knot collections are equal * weight values are equal
See Also

©  Bricsys NV. All rights reserved.