NurbCurve3dData Structure

This structure stores the data that defines a NurbCurve3d object.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryNurbCurve3dData

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct NurbCurve3dData

The NurbCurve3dData type exposes the following members.

Properties
  Name Description
Public property ControlPoints  
Public property Degree  
Public property Knots  
Public property Periodic  
Public property Rational  
Public property Weights  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method IsEqualTo Checks whether this nurb curve data is equal to the passed nurb curve data.
Top
Operators
  Name Description
Public operatorStatic member Equality(NurbCurve3dData, NurbCurve3dData) Equality operator for the NurbCurve3dData structure. Checks whether curve data is equal.
Public operatorStatic member Inequality(NurbCurve3dData, NurbCurve3dData) Inequality operator for the NurbCurve3dData structure. Checks whether curve data is not equal.
Top
See Also

©  Bricsys NV. All rights reserved.