Retrieves the arc length of the curve between
the two parameter values.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public double GetLength(
double fromParameter,
double toParameter,
double tolerance
)
Public Function GetLength (
fromParameter As Double,
toParameter As Double,
tolerance As Double
) As Double
public:
double GetLength(
double fromParameter,
double toParameter,
double tolerance
)
member GetLength :
fromParameter : float *
toParameter : float *
tolerance : float -> float
Parameters
- fromParameter Double
- [in] First parameter value that represents the start of the
interval.
- toParameter Double
- [in] Second parameter value that represents the end of the
interval.
- tolerance Double
- [in] Geometric tolerance.
Return Value
Double
The length as a value of the double type.
See Also