Curve3d Class

This .NET class wraps the OdGeCurve3d class.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometryCurve3d
          More

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public abstract class Curve3d : Entity3d

The Curve3d type exposes the following members.

Properties
Methods
  Name Description
Public methodStatic member Create Creates a Curve3d object based on the passed pointer.
Public method EvaluatePoint Retrieves the point on the curve corresponding to the specified parameter value.
Public method Explode Explodes the curve into its component sub-curves.
Public method GetArea(Double, Double) Retrieves the area of the parametric interval defined by the passed start and end parameters.
Public method GetArea(Double, Double, Tolerance) Retrieves the area of the parametric interval defined by the passed start and end parameters.
Public method GetBoundBlockOf Retrieves the oriented bounding box of the specified sub-interval of this curve.
Public method GetClosestPointTo(Curve3d) Retrieves the closest points between this curve and the passed curve.
Public method GetClosestPointTo(Point3d) Retrieves the closest point on this curve to the specified point.
Public method GetClosestPointTo(Curve3d, Tolerance) Retrieves the closest points between this curve and the passed curve within a specified tolerance.
Public method GetClosestPointTo(Point3d, Tolerance) Retrieves the closest point on this curve to the specified point within a specified tolerance.
Public method GetDistanceTo(Curve3d) Retrieves the distance of the closest points between this curve and the passed curve.
Public method GetDistanceTo(Point3d) Retrieves the distance of the closest point on this curve and the specified point.
Public method GetDistanceTo(Curve3d, Tolerance) Retrieves the distance of the closest points between this curve and the passed curve within a specified tolerance.
Public method GetDistanceTo(Point3d, Tolerance) Retrieves the distance of the closest point on this curve and the specified point within a specified tolerance.
Public method GetInterval Retrieves the parametric interval of this curve.
Public method GetLength Retrieves the arc length of the curve between the two parameter values.
Public method GetNormalPoint(Point3d) Retrieves the point on this curve where normal extends through the passed point.
Public method GetNormalPoint(Point3d, Tolerance) Retrieves the point on this curve where normal extends through the passed point within the specified tolerance.
Public method GetOrthoBoundBlockOf Retrieves the bounding box of the specified parametric range of this curve. Bounding box sides are parallel to the coordinate axes.
Public method GetOrthoProjectEntity(Plane) Retrieves the entity representing the curve's orthogonal projection onto the projection plane.
Public method GetOrthoProjectEntity(Plane, Tolerance) Retrieves the entity representing the curve's orthogonal projection onto the projection plane.
Public method GetParameterAtLength Retrieves the parameter value of the point whose arc length distance is the input length.
Public method GetParameterOf(Point3d) Retrieves the parameter value of a point.
Public method GetParameterOf(Point3d, Tolerance) Retrieves the parameter value of a point within a specified tolerance.
Public method GetProjectedClosestPointTo(Curve3d, Vector3d) Retrieves the point on this curve closest to the specified curve, and the point on the passed curve closest to this curve, when this curve is projected in the specified direction.
Public method GetProjectedClosestPointTo(Point3d, Vector3d) Retrieves the point on this curve closest to the specified point when projected in the specified direction.
Public method GetProjectedClosestPointTo(Curve3d, Vector3d, Tolerance) Retrieves the points on this curve closest to the specified curve, and the point on the other curve closest to this curve, when this curve is projected in the specified direction.
Public method GetProjectedClosestPointTo(Point3d, Vector3d, Tolerance) Retrieves the point on this curve closest to the specified point when projected in the specified direction.
Public method GetProjectedEntity(Plane, Vector3d) Retrieves the entity representing the curve's projection onto the projection plane.
Public method GetProjectedEntity(Plane, Vector3d, Tolerance) Retrieves the entity representing the curve's projection onto the projection plane.
Public method GetReverseParameterCurve Reverses the parameter *direction* of this *curve*.
Public method GetSamplePoints(Int32) Retrieves an array of sample points along this curve.
Public method GetSamplePoints(Double, Double, Double) Retrieves specified arrays of sample points along this curve and their parameter values.
Public method GetSplitCurves Retrieves two segments of this curve split at the specified parameter value.
Public method GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType) Receives one or more offset curves that represent the trimmed offset of the curve.
Public method GetTrimmedOffset(Double, Vector3d, OffsetCurveExtensionType, Tolerance) Receives one or more offset curves that represent the trimmed offset of the curve.
Public method IsClosed Checks whether the curve is closed.
Public method IsClosed(Tolerance) Checks whether the curve is closed within a specified tolerance.
Public method IsCoplanarWith(Curve3d, Plane) Checks whether the specified curve entity is coplanar with this curve and returns the common plane.
Public method IsCoplanarWith(Curve3d, Plane, Tolerance) Checks whether the specified curve entity is coplanar with this curve and returns the common plane.
Public method IsDegenerate(Entity3d) Checks whether this curve is degenerate and returns the type of entity that the curve degenerates to (if degenerate).
Public method IsDegenerate(Entity3d, Tolerance) Checks whether this curve is degenerate and returns the type of entity that the curve degenerates to (if degenerate).
Public method IsLinear(Line3d) Checks whether this curve is linear.
Public method IsLinear(Line3d, Tolerance) Checks whether this curve is linear within a specified tolerance.
Public method IsOn(Double) Checks whether a specified parameter value is within a valid parametric range of the curve.
Public method IsOn(Point3d) Checks whether a specified point lies on this curve.
Public method IsOn(Double, Tolerance) Checks whether a specified parameter value is within a valid parametric range of the curve.
Public method IsOn(Point3d, Double) Checks whether a specified point lies on this curve.
Public method IsOn(Point3d, Tolerance) Checks whether a specified point lies on this curve within a specified tolerance.
Public method IsOn(Point3d, Double, Tolerance) Checks whether a specified point lies on this curve.
Public method IsPeriodic Checks whether the curve is periodic.
Public method IsPlanar(Plane) Checks whether this curve is planar. If the curve is a line, this function returns an arbitrary plane that contains the line. The plane parameter contains meaningful data only if this function returns a value of true.
Public method IsPlanar(Plane, Tolerance) Checks whether this curve is planar within a specified tolerance. If the curve is a line, this function returns an arbitrary plane that contains the line. The plane parameter contains meaningful data only if this function returns a value of true.
Public method SetInterval Sets the parametric range of this curve.
Top
See Also
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometryCurve3d
          Teigha.GeometryCircularArc3d
          Teigha.GeometryCompositeCurve3d
          Teigha.GeometryEllipticalArc3d
          Teigha.GeometryExternalCurve3d
          Teigha.GeometryLinearEntity3d
          Teigha.GeometryOffsetCurve3d
          Teigha.GeometrySplineEntity3d
          Teigha.GeometrySurfaceCurve2dTo3d

©  Bricsys NV. All rights reserved.