DeepCloneType Enumeration
|
Deep clone types.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public enum DeepCloneType
Public Enumeration DeepCloneType
public enum class DeepCloneType
Members
Member name |
Value |
Description |
Copy |
0 |
Copy, array, mirror. |
Explode |
1 |
Explode. |
Block |
2 |
Block definition. |
XrefBind |
3 |
Bind external reference. |
SymbolTableMerge |
4 |
Attach external reference, DxfIn, IgesIn. |
Insert |
6 |
Insert a .dwg file. |
Wblock |
7 |
Wblock. |
Objects |
8 |
Database.deepCloneObjects(). |
XrefInsert |
9 |
Insert external reference Insert, bind external reference. |
InsertCopy |
10 |
Insert(). |
WblockObjects |
11 |
Wblock objects. |
See Also