AssocActionIsExternalDependency Method
|
Checks whether the specified dependency, which
is owned by this action, depends on the database object that is not
this action and is not owned by this action. If the dependency
doesn't depend on any object, it's also assumed external.
Namespace: Teigha.DatabaseServices
Assembly: TD_MgdDbConstraints (in
TD_MgdDbConstraints.dll) Version: 0.0.0.0
Syntax
public bool IsExternalDependency(
AssocDependency dependency
)
Public Function IsExternalDependency (
dependency As AssocDependency
) As Boolean
public:
bool IsExternalDependency(
AssocDependency^ dependency
)
member IsExternalDependency :
dependency : AssocDependency -> bool
Parameters
- dependency AssocDependency
- [in] Dependency to check. It must be open at least for read
operations.
Return Value
Boolean
true if the specified dependency is
external,
false otherwise.
See Also