MentalRayRenderSettingsTraitsTraceParameter Structure

This structure stores the maximum depth (recursion level) for traced rays or photons.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GraphicsInterfaceMentalRayRenderSettingsTraitsTraceParameter

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct MentalRayRenderSettingsTraitsTraceParameter

The MentalRayRenderSettingsTraitsTraceParameter type exposes the following members.

Constructors
  Name Description
Public method MentalRayRenderSettingsTraitsTraceParameter Constructor for the MentalRayRenderSettingsTraitsSamplingParameter structure. Specifies the maximum depth (recursion level) for traced rays or photons.
Top
Properties
  Name Description
Public property Reflection Property that represents the maximum recursion level of reflection photons or rays.
Public property Refraction Property that represents the maximum recursion level of refraction photons or rays.
Public property Sum Maximum recursion level of reflection and refraction photons or rays, combined.
Top
Methods
  Name Description
Top
See Also

©  Bricsys NV. All rights reserved.