MentalRayRenderSettingsTraitsTraceParameter
Constructor
|
Constructor for the
MentalRayRenderSettingsTraitsSamplingParameter structure. Specifies
the maximum depth (recursion level) for traced rays or
photons.
Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public MentalRayRenderSettingsTraitsTraceParameter(
int reflect,
int refract,
int s
)
Public Sub New (
reflect As Integer,
refract As Integer,
s As Integer
)
public:
MentalRayRenderSettingsTraitsTraceParameter(
int reflect,
int refract,
int s
)
new :
reflect : int *
refract : int *
s : int -> MentalRayRenderSettingsTraitsTraceParameter
Parameters
- reflect Int32
- [in] Maximum recursion level of reflection photons or rays,
greater than or equal to 0.
- refract Int32
- [in] Maximum recursion level of refraction photons or rays,
greater than or equal to 0.
- s Int32
- [in] Maximum recursion level of reflection and refraction
photons or rays, combined.
See Also