DimensionDimblk1s Property
|
Sets or gets the name of the arrowhead block
at the end of the first dimension line.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public string Dimblk1s { get; set; }
Public Property Dimblk1s As String
Get
Set
public:
property String^ Dimblk1s {
String^ get ();
void set (String^ value);
}
member Dimblk1s : string with get, set
Property Value
String
Remarks
The following
names are applicable:
Value |
Description |
"None" |
None |
"Closed" |
Closed |
"Dot" |
Dot |
"ClosedBlank" |
Closed blank |
"Oblique" |
Oblique |
"ArchTick" |
Architectural tick |
"Open" |
Open |
"Origin" |
Origin marker |
"Origin2" |
Origin marker 2 |
"Open90" |
Open 90 degrees |
"Open30" |
Open 30 degrees |
"DotBlank" |
Dot blank |
"DotSmall" |
Dot small |
"BoxFilled" |
Box filled |
"BoxBlank" |
Box blank |
"DatumFilled" |
Datum marker filled |
"DatumBlank" |
Datum marker blank |
"Integral" |
Integral |
"Small" |
Dot small blank |
The Dimsah property should be set to true to use arrowhead types
set by the Dimblk1s property, and set to false if a type set by
Dimblks is used.
See Also