SurfaceSurfaceIntersectorGetType(Int32) Method
|
Retrieves the type of the specified
intersection. Currently not implemented.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public SurfaceSurfaceIntersectorType GetType(
int number
)
Public Function GetType (
number As Integer
) As SurfaceSurfaceIntersectorType
public:
SurfaceSurfaceIntersectorType GetType(
int number
)
member GetType :
number : int -> SurfaceSurfaceIntersectorType
Parameters
- number Int32
- [in] The zero-based index of the intersection.
Return Value
SurfaceSurfaceIntersectorType
SurfaceSurfaceIntersectorType which can be one of the following: *
Transverse - Non-tangent intersection. * Tangent - Tangent
intersection with surface normals codirectional at any point within
the component. * AntiTangent - Tangent intersection with surface
normals antidirectional at any point within the component.
Remarks
This method throws
one of the following exceptions if the method fails: *
kXXIndexOutOfRange - Index out of range. * kXXUnknown - Intersector
is not initialized.
See Also