SurfaceSurfaceIntersector Class

This class holds the intersection data of two surfaces. This object contains handles to surface objects but does not own them. Calculation of the intersection is performed by a query function. Any output geometry from an intersection object is owned by the caller. If one of the objects is deleted, the intersection must be recalculated. If one of the object is NULL, a kXXUnknown exception is thrown and a non-valid value is returned. For more information, see Working with Surfaces.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometrySurfaceSurfaceIntersector

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public class SurfaceSurfaceIntersector : Entity3d

The SurfaceSurfaceIntersector type exposes the following members.

Constructors
  Name Description
Public method SurfaceSurfaceIntersector Default constructor for the SurfaceSurfaceIntersector class. Creates a default corresponding C++ object with NULL surfaces, default tolerance, flag that indicates whether surfaces overlap set to false, and a flag that indicates that data is not initialized.
Public method SurfaceSurfaceIntersector(Surface, Surface) Constructor for the SurfaceSurfaceIntersector class. Creates a surface intersector with two specified surface objects.
Public method SurfaceSurfaceIntersector(Surface, Surface, Tolerance) Constructor for the SurfaceSurfaceIntersector class. Creates a surface intersector with two specified surface objects and a tolerance.
Top
Properties
  Name Description
Public property NumResults  
Public property Surface1  
Public property Surface2  
Public property Tolerance  
Top
Methods
  Name Description
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method GetDimension Returns the dimension of the intersection point by its index.
Public method GetIntersectionConfigurations Retrieves the surface configurations on either side of the intersection. Currently not implemented.
Public method GetIntersectPointParameters Retrieves the parameter pairs (U, V) for the specified intersection point with respect to each surface.
Public method GetType(Int32) Retrieves the type of the specified intersection. Currently not implemented.
Public method IntersectCurve Retrieves the 3D curve representing the specified intersection.
Public method IntersectParameterCurve Retrieves the 2D curve representing the specified intersection.
Public method IntersectPoint Retrieves the 3D intersection point at the specified index.
Public method Set(Surface, Surface) Sets surfaces for an intersection.
Public method Set(Surface, Surface, Tolerance) Sets surfaces for an intersection and a tolerance to compute intersections.
Top
See Also

©  Bricsys NV. All rights reserved.