Solid3dCreateFrustum
Method
|
Creates a WCS-aligned frustum centered at the
world origin.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void CreateFrustum(
double height,
double radiusAlongX,
double radiusAlongY,
double topRadius
)
Public Overridable Sub CreateFrustum (
height As Double,
radiusAlongX As Double,
radiusAlongY As Double,
topRadius As Double
)
public:
virtual void CreateFrustum(
double height,
double radiusAlongX,
double radiusAlongY,
double topRadius
)
abstract CreateFrustum :
height : float *
radiusAlongX : float *
radiusAlongY : float *
topRadius : float -> unit
override CreateFrustum :
height : float *
radiusAlongX : float *
radiusAlongY : float *
topRadius : float -> unit
Parameters
- height Double
- [in] Height of the frustum.
- radiusAlongX Double
- [in] Radius along the WCS x-axis.
- radiusAlongY Double
- [in] Radius along the WCS y-axis.
- topRadius Double
- [in] Dimension of the top radius.
Remarks
This method can
generate a frustum that is any one of the following: * A circular
cylinder (when radiusAlongX is equal to topRadius and radiusAlongX
and radiusAlongY are the same). * An elliptical cylinder (when
radiusAlongX is equal to topRadius and radiusAlongX and
radiusAlongY are not the same). * A circular cone (when topRadius
is zero and radiusAlongX and radiusAlongY are the same). * An
elliptical cone (when topRadius is zero and radiusAlongX and
radiusAlongY are not the same). * A truncated circular cone (when
topRadius is not zero but not equal to radiusAlongX and
radiusAlongX and radiusAlongY are the same). * A truncated
elliptical cone (when topRadius is not zero but not equal to
radiusAlongX and radiusAlongX and radiusAlongY are not the same).
The following constraints are applied: * height >= 1e-6 *
radiusAlongX >= 1e-6 * radiusAlongY >= 1e-6 * topRadius >=
1e-6
See Also