This enum class represents update options for
data links.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
Public Enumeration UpdateOption
public enum class UpdateOption
Members
Member name |
Value |
Description |
None |
0 |
No update options. |
SkipFormat |
131,072 |
Update only content, ignoring cell format. |
UpdateRowHeight |
262,144 |
Update the row height of linked cells to match the source. |
UpdateColumnWidth |
524,288 |
Update the column width of linked cells to match the
source. |
AllowSourceUpdate |
1,048,576 |
Allow writing from data to source. |
ForceFullSourceUpdate |
2,097,152 |
Write everything (i.e. not only modified data) while writing to
the source. This option is valid only while updating source from
data. |
OverwriteContentModifiedAfterUpdate |
4,194,304 |
Overwrite all the content changes done to the linked data since
the data was updated from source last time. This option is valid
only while updating data from source. |
OverwriteFormatModifiedAfterUpdate |
8,388,608 |
Overwrite all the format changes done to the linked data since
the data was updated from source last time. This option is valid
only while updating data from source. |
ForPreview |
16,777,216 |
Update is performed for showing preview in preview window. |
IncludeXrefs |
33,554,432 |
Update data links within xrefs. |
See Also