NurbSurfaceSetWeight Method

Sets the weight value at a specified position in the weights array. If the surface is not rational, the method does nothing.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public void SetWeight(
        int iUDegree,
        int iVDegree,
        double dWeight
)

Parameters

iUDegree  Int32
[in] The index of a weight value in the u-direction. Index starts from the 0 value.
iVDegree  Int32
[in] The index of a weight value in the v-direction. Index starts from the 0 value.
dWeight  Double
[in] A new weight value to be set at a specified position.
Remarks
If the surface doesn't contain weight information, the method throws the eFail exception. If the iUDegree or iVDegree value is out of range, throws the eOutOfRange exception. If this method is not implemented for a specific modeler, throws the eNotImplementedYet exception.
See Also

©  Bricsys NV. All rights reserved.