CompositeParameter Structure

This data type stores the data that specifies the parameter of a point on a composite curve. This data consists of the point's parameter value and the index of the curve on which the point resides.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometryCompositeParameter

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct CompositeParameter

The CompositeParameter type exposes the following members.

Constructors
  Name Description
Public method CompositeParameter Constructor for the CompositeParameter structure. Constructs the structure with the passed segment index and local parameter value.
Top
Properties
  Name Description
Public property LocalParameter  
Public property SegmentIndex  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method IsEqualTo(CompositeParameter)  
Public method IsEqualTo(CompositeParameter, Tolerance)  
Top
Operators
See Also

©  Bricsys NV. All rights reserved.