Offsets all faces by the specified
distance.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void OffsetBody(
double offsetDistance
)
Public Overridable Sub OffsetBody (
offsetDistance As Double
)
public:
virtual void OffsetBody(
double offsetDistance
)
abstract OffsetBody :
offsetDistance : float -> unit
override OffsetBody :
offsetDistance : float -> unit
Parameters
- offsetDistance Double
- [in] Offset distance.
Remarks
If a face has
surfaces that cannot be offset, it is removed. Therefore, the
offset operation can cause the solid to become invalid. This method
is implemented only for the Spatial modeler.
See Also