UtilityEffectiveBlockTableRecord
Method
|
Returns the ObjectId of effective
BlockTableRecord for the specified parametric block
(BlockReference)
Namespace: Bricscad.Parametric
Assembly: BrxMgd (in BrxMgd.dll) Version:
24.0.1.0
Syntax
public static ObjectId EffectiveBlockTableRecord(
ObjectId blockRefId
)
Public Shared Function EffectiveBlockTableRecord (
blockRefId As ObjectId
) As ObjectId
public:
static ObjectId EffectiveBlockTableRecord(
ObjectId blockRefId
)
static member EffectiveBlockTableRecord :
blockRefId : ObjectId -> ObjectId
Parameters
- blockRefId ObjectId
- ObjectId of the BlockReference to query
Return Value
ObjectId
ObjectId of the BlockTableRecord used by this parametric block. If
BlockTableRecord is anonymous then the ObjectId of the original
BlockTableRecord (from which that anonymous BlockTableRecord was
derived from) is returned.
See Also