Utility Class

Inheritance Hierarchy
SystemObject
  Bricscad.ParametricUtility

Namespace: Bricscad.Parametric
Assembly: BrxMgd (in BrxMgd.dll) Version: 24.0.1.0
Syntax
public sealed class Utility

The Utility type exposes the following members.

Constructors
  Name Description
Public method Utility Initializes a new instance of the Utility class
Top
Methods
  Name Description
Public methodStatic member EffectiveBlockRefName Returns the effective name for the specified parametric block (BlockReference)
Public methodStatic member EffectiveBlockTableRecord Returns the ObjectId of effective BlockTableRecord for the specified parametric block (BlockReference)
Public methodStatic member Get3dConstraintsGroup Returns the 3D constraints group for specified block table record
Public methodStatic member GetAllConstraintsGroups3d Returns all 3D constraints groups for specified database
Public methodStatic member GetBlockParameter Returns block parameter with given name in given block reference
Public methodStatic member GetBlockParameterNames Returns the names of all parameters of specified parametric block
Public methodStatic member GetEntityGuiName Returns the constrained entity's GUI name (as shown in MechanicalBrowser)
Public methodStatic member SetEntityGuiName Assigns a new GUI name to the constrained entity's GUI name (as shown in MechanicalBrowser)
Top
See Also

©  Bricsys NV. All rights reserved.