Represents data types that can be stored by
the DataCell object.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
Public Enumeration CellType
public enum class CellType
Members
Member name |
Value |
Description |
Unknown |
0 |
Unknown data type. |
Integer |
1 |
Signed 32-bit integer. |
Double |
2 |
Double. |
CharPtr |
3 |
Char pointer. |
Point |
4 |
3D point. |
ObjectId |
5 |
Database-resident object identifier (ObjectId). |
HardOwnerId |
6 |
HardOwnershipId. |
SoftOwnerId |
7 |
SoftOwnershipId. |
HardPtrId |
8 |
HardPointerId. |
SoftPtrId |
9 |
SoftPointerId. |
Bool |
10 |
Boolean. |
Vector |
11 |
3D vector. |
See Also