PolygonMeshSurfaceFit(PolyMeshType,
Int32, Int32) Method
|
Surface fits a smooth surface to this
PolygonMesh entity.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SurfaceFit(
PolyMeshType surfType,
int surfU,
int surfV
)
Public Sub SurfaceFit (
surfType As PolyMeshType,
surfU As Integer,
surfV As Integer
)
public:
void SurfaceFit(
PolyMeshType surfType,
int surfU,
int surfV
)
member SurfaceFit :
surfType : PolyMeshType *
surfU : int *
surfV : int -> unit
Parameters
- surfType PolyMeshType
- [in] Surface type (overrides the SURFTYPE system
variable).
- surfU Int32
- [in] M surface density (overrides the SURFU system
variable).
- surfV Int32
- [in] N surface density (overrides the SURFV system
variable.
Remarks
surfU and surfV
must be in the range [2..200]. Name Value Description SimpleMesh 0
Simple mesh QuadSurfaceMesh 5 Quadratic B-spline fitting
CubicSurfaceMesh 6 Cubic B-spline fitting BezierSurfaceMesh 8
Bezier surface fitting
See Also