MaterialSpecularComponent Structure

This structure stores the specular component (channel) for the material.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GraphicsInterfaceMaterialSpecularComponent

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct MaterialSpecularComponent

The MaterialSpecularComponent type exposes the following members.

Constructors
  Name Description
Public method MaterialSpecularComponent Constructor for the MaterialSpecularComponent structure. Constructs an object with the specified specular color, material map (that defines how specular values are mapped), and glossiness of the specular.
Top
Properties
  Name Description
Public property Color  
Public property Gloss  
Public property Map  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method ToString Returns an equivalent string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(MaterialSpecularComponent, MaterialSpecularComponent) Equality operator for the MaterialSpecularComponent structure. Checks whether input specular components are equal.
Public operatorStatic member Inequality(MaterialSpecularComponent, MaterialSpecularComponent) Inequality operator for the MaterialSpecularComponent structure. Checks whether input specular components are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.