SurfaceSurfaceIntersectorConfigurationsIsEqualTo Method
|
Checks whether the specified intersector
configuration is equal to this intersector configuration.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsEqualTo(
SurfaceSurfaceIntersectorConfigurations a
)
Public Function IsEqualTo (
a As SurfaceSurfaceIntersectorConfigurations
) As Boolean
public:
bool IsEqualTo(
SurfaceSurfaceIntersectorConfigurations a
)
member IsEqualTo :
a : SurfaceSurfaceIntersectorConfigurations -> bool
Parameters
- a SurfaceSurfaceIntersectorConfigurations
- [in] Surface-surface intersector configuration to compare.
Return Value
Boolean
true if all the following conditions are met: * Configurations for
first surfaces to the left of intersections are equal *
Configurations for second surfaces to the left of intersections are
equal * Configurations for first surfaces to the right of
intersections are equal * Configurations for second surfaces to the
right of intersections are equal * Intersection types are equal *
Intersection dimensions are equal
See Also