SurfaceSurfaceIntersectorConfigurations Structure

This structure that stores the left and right surface configuration data for each of two intersecting surfaces. This structure is used for the SurfaceSurfaceIntersector.GetIntersectionConfigurations method.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GeometrySurfaceSurfaceIntersectorConfigurations

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct SurfaceSurfaceIntersectorConfigurations

The SurfaceSurfaceIntersectorConfigurations type exposes the following members.

Properties
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method IsEqualTo Checks whether the specified intersector configuration is equal to this intersector configuration.
Top
Operators
  Name Description
Public operatorStatic member Equality(SurfaceSurfaceIntersectorConfigurations, SurfaceSurfaceIntersectorConfigurations) Equality operator for the SurfaceSurfaceIntersectorConfigurations structure. Checks whether specified intersector configurations are equal.
Public operatorStatic member Inequality(SurfaceSurfaceIntersectorConfigurations, SurfaceSurfaceIntersectorConfigurations) Inequality operator for the SurfaceSurfaceIntersectorConfigurations structure. Checks whether specified intersector configurations are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.