Creates a mesh of a wedge.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetWedge(
double xLen,
double yLen,
double zLen,
int divLength,
int divWidth,
int divHeight,
int divSlope,
int divCap,
int smoothLevel
)
Public Sub SetWedge (
xLen As Double,
yLen As Double,
zLen As Double,
divLength As Integer,
divWidth As Integer,
divHeight As Integer,
divSlope As Integer,
divCap As Integer,
smoothLevel As Integer
)
public:
void SetWedge(
double xLen,
double yLen,
double zLen,
int divLength,
int divWidth,
int divHeight,
int divSlope,
int divCap,
int smoothLevel
)
member SetWedge :
xLen : float *
yLen : float *
zLen : float *
divLength : int *
divWidth : int *
divHeight : int *
divSlope : int *
divCap : int *
smoothLevel : int -> unit
Parameters
- xLen Double
- [in] Wedge depth.
- yLen Double
- [in] Wedge width.
- zLen Double
- [in] Wedge height.
- divLength Int32
- [in] Specifies how many divisions are made along the depth
direction.
- divWidth Int32
- [in] Specifies how many divisions are made along the width
direction.
- divHeight Int32
- [in] Specifies how many divisions are made along the height
direction.
- divSlope Int32
- [in] Specifies how many divisions are made along the slope
direction.
- divCap Int32
- [in] Specifies how many radial divisions are made for the base
face.
- smoothLevel Int32
- [in] Level of smoothness.
See Also