NurbCurve3d(Int32, PolylineCurve3d, Boolean) Constructor

Constructor for the NurbCurve3d class. Constructs a NURBS curve with a specified degree value, fit polyline, and a flag specifying whether to make a closed curve.

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public NurbCurve3d(
        int degree,
        PolylineCurve3d fitPolyline,
        bool periodic
)

Parameters

degree  Int32
[in] Curve degree.
fitPolyline  PolylineCurve3d
[in] Polyline fit points that are interpolated by the curve.
periodic  Boolean
[in] Flag that specifies whether to make the curve periodic (a closed curve).
Remarks
High degree values make the curve more flexible. For example, degree of 1 is used to define a polyline, and degree of 2 is used to define a NURBS circle, etc.
See Also

©  Bricsys NV. All rights reserved.