NurbCurve3d Class

This class represents non-uniform rational B-splines (NURBS) in 3D space. For more information, see Working with NURBS Curves.
Inheritance Hierarchy
SystemObject
  SystemMarshalByRefObject
    Teigha.RuntimeDisposableWrapper
      Teigha.GeometryEntity3d
        Teigha.GeometryCurve3d
          Teigha.GeometrySplineEntity3d
            Teigha.GeometryNurbCurve3d

Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public sealed class NurbCurve3d : SplineEntity3d

The NurbCurve3d type exposes the following members.

Constructors
  Name Description
Public method NurbCurve3d Default constructor for the NurbCurve3d class. With this constructor no actual data is stored in the object.
Public method NurbCurve3d(EllipticalArc3d) Constructor for the NurbCurve3d class. Constructs a 3D curve from a passed 3D elliptical arc.
Public method NurbCurve3d(LineSegment3d) Constructor for the NurbCurve3d class. Constructs a 3D curve from a passed 3D line segment.
Public method NurbCurve3d(Point3dCollection) Constructor for the NurbCurve3d class. Constructs a 3D curve interpolating a given array of 3D points.
Public method NurbCurve3d(Point3dCollection, Tolerance) Constructor for the NurbCurve3d class. Constructs a 3D curve interpolating a given array of 3D points within a given tolerance.
Public method NurbCurve3d(Int32, PolylineCurve3d, Boolean) Constructor for the NurbCurve3d class. Constructs a NURBS curve with a specified degree value, fit polyline, and a flag specifying whether to make a closed curve.
Public method NurbCurve3d(Point3dCollection, Vector3dCollection, Boolean) Constructor for the NurbCurve3d class. Constructs a 3D polynomial curve interpolating a given array of 3D points.
Public method NurbCurve3d(Int32, KnotCollection, Point3dCollection, Boolean) Constructor for the NurbCurve3d class. Constructs a 3D curve according to the passed parameters.
Public method NurbCurve3d(Point3dCollection, Vector3dCollection, Tolerance, Boolean) Constructor for the NurbCurve3d class. Constructs a 3D polynomial curve interpolating a given array of 3D points according to the specified tolerance.
Public method NurbCurve3d(Int32, KnotCollection, Point3dCollection, DoubleCollection, Boolean) Constructor for the NurbCurve3d class. Constructs a 3D curve according to the passed parameters.
Public method NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean) Constructor for the NurbCurve3d class. Constructs a 3D curve interpolating a given array of 3D points and using given derivatives at the start point and endpoint.
Public method NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, KnotParameterizationEnum) Constructor for the NurbCurve3d class. Constructs a 3D curve interpolating a given array of 3D points, knot parameterization, and having given derivatives at the start point and endpoint.
Public method NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, Tolerance) Constructor for the NurbCurve3d class. Constructs a 3D curve interpolating a given array of 3D points according to the specified tolerance and using given derivatives at the start point and endpoint.
Public method NurbCurve3d(Point3dCollection, Vector3d, Vector3d, Boolean, Boolean, KnotParameterizationEnum, Tolerance) Constructor for the NurbCurve3d class. Constructs a 3D curve interpolating a given array of 3D points, knot parameterization, and having given derivatives at the start point and endpoint.
Top
Properties
  Name Description
Public property DefinitionData  
Public property EvalMode  
Public property FitData  
Public property FitKnotParameterization  
Public property FitTolerance  
Public property NumFitPoints  
Public property NumWeights  
Top
Methods
  Name Description
Public method AddControlPointAt Adds a control point at the specified knot.
Public method AddFitPointAt Inserts a fit point at the specified index.
Public method AddKnot Adds a new knot to the spline knot array.
Public methodStatic member Create Creates an object based on the passed pointer and returns a handle to the created object.
Public method DeleteControlPointAt Deletes a control point at the specified index.
Public method DeleteFitPointAt Removes a fit point with the specified index.
Public method ElevateDegree Increases the spline degree by the specified value.
Public method GetFitPointAt Retrieves the fit point at the specified index.
Public method GetFitTangents Retrieves the start and end tangents if this spline was constructed with fit data.
Public method GetParametersOfC1Discontinuity Returns parameter values of all points on the spline where the tangent vector is not continuous. The returned array contains points where the tangent vector to the left of the point is not equal to the tangent vector to the right of the point.
Public method GetParametersOfC1Discontinuity(Tolerance) Returns parameter values of all points on the spline where the tangent vector is not continuous according to the specified tolerance. The returned array contains points where the tangent vector to the left of the point is not equal to the tangent vector to the right of the point.
Public method GetParametersOfG1Discontinuity Returns parameter values of all points on the spline where the tangent vector is not continuous. The returned array contains points where the tangent vector to the left of the point does not have the same direction to the tangent vector to the right of the point.
Public method GetParametersOfG1Discontinuity(Tolerance) Returns parameter values of all points on the spline where the tangent vector is not continuous according to the specified tolerance. The returned array contains points where the tangent vector to the left of the point does not have the same direction to the tangent vector to the right of the point.
Public method GetWeightAt Returns the weight at the specified index.
Public method HardTrimByParams Trims this NURBS curve by the new start and end parameters.
Public method InsertKnot Inserts a new knot to the spline knot array.
Public method JoinWith Joins the specified OdGeNurbCurve3d with this spline and returns a reference to the recomputed spline.
Public method MakeClosed Makes an open spline closed, and returns a reference to this spline.
Public method MakeNonPeriodic Makes this spline non-periodic (if it is not).
Public method MakeOpen Makes a closed spline open.
Public method MakePeriodic Makes this spline periodic (if it is not).
Public method MakeRational Makes this spline rational (if it is not).
Public method PurgeFitData Purges the fit data defining this spline. The fit data consists of the fit points, fit tolerance, start tangent, and end tangent. The definition of the spline is unchanged.
Public method SetEvaluateMode Sets the evaluation mode.
Public method SetFitData(Int32, Point3dCollection) Sets the fit data for this spline.
Public method SetFitData(Int32, Point3dCollection, Tolerance) Sets the fit data for this spline.
Public method SetFitData(Point3dCollection, Vector3d, Vector3d) Sets the fit data for this spline.
Public method SetFitData(Point3dCollection, Vector3d, Vector3d, Tolerance) Sets the fit data for this spline.
Public method SetFitData(KnotCollection, Point3dCollection, Vector3d, Vector3d, Boolean) Sets the fit data for this spline.
Public method SetFitData(Point3dCollection, Vector3d, Vector3d, KnotParameterizationEnum, Tolerance) Sets the fit data for this spline.
Public method SetFitData(KnotCollection, Point3dCollection, Vector3d, Vector3d, Tolerance, Boolean) Sets the fit data for this spline.
Public method SetFitPointAt Sets the fit point at the specified index.
Public method SetFitTangents Sets the fit tangents for this spline.
Public method SetWeightAt Sets the weight at the specified index.
Top
See Also

©  Bricsys NV. All rights reserved.