AcadPaperSpaceClass Class

Inheritance Hierarchy
SystemObject
  BricscadDbAcadPaperSpaceClass

Namespace: BricscadDb
Assembly: Interop.BricscadDb (in Interop.BricscadDb.dll) Version: 24.0.0.0
Syntax
public class AcadPaperSpaceClass : IAcadPaperSpace, 
        AcadPaperSpace, IAcadObjectEvents_Event

The AcadPaperSpaceClass type exposes the following members.

Constructors
  Name Description
Public method AcadPaperSpaceClass Initializes a new instance of the AcadPaperSpaceClass class
Top
Properties
Methods
  Name Description
Public method add_Modified  
Public method Add3DFace  
Public method Add3DMesh  
Public method Add3DPoly  
Public method AddArc  
Public method AddAttribute  
Public method AddBox  
Public method AddCircle  
Public method AddCone  
Public method AddCustomObject  
Public method AddCylinder  
Public method AddDim3PointAngular  
Public method AddDimAligned  
Public method AddDimAngular  
Public method AddDimArc  
Public method AddDimDiametric  
Public method AddDimOrdinate  
Public method AddDimRadial  
Public method AddDimRadialLarge  
Public method AddDimRotated  
Public method AddEllipse  
Public method AddEllipticalCone  
Public method AddEllipticalCylinder  
Public method AddEmbeddedRaster  
Public method AddExtrudedSolid  
Public method AddExtrudedSolidAlongPath  
Public method AddHatch  
Public method AddLeader  
Public method AddLightWeightPolyline  
Public method AddLine  
Public method AddMInsertBlock  
Public method AddMLeader  
Public method AddMLine  
Public method AddMText  
Public method AddPoint  
Public method AddPolyfaceMesh  
Public method AddPolyline  
Public method AddPViewport  
Public method AddRaster  
Public method AddRay  
Public method AddRegion  
Public method AddRevolvedSolid  
Public method AddSection  
Public method AddShape  
Public method AddSolid  
Public method AddSphere  
Public method AddSpline  
Public method AddTable  
Public method AddText  
Public method AddTolerance  
Public method AddTorus  
Public method AddTrace  
Public method AddWedge  
Public method AddXline  
Public method AttachExternalReference  
Public method Bind  
Public method Delete  
Public method Detach  
Public method Erase  
Public method GetEnumerator  
Public method GetExtensionDictionary  
Public method GetXData  
Public method InsertBlock  
Public method Item  
Public method Reload  
Public method remove_Modified  
Public method SetXData  
Public method Unload  
Top
Events
  Name Description
Public event Modified  
Top
See Also

©  Bricsys NV. All rights reserved.