Polyline2dAppendVertex Method

Appends the specified vertex entity to this polyline entity, and makes this polyline entity its owner.

Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public ObjectId AppendVertex(
        Vertex2d vertexToAppend
)

Parameters

vertexToAppend  Vertex2d
[in] Vertex to append.

Return Value

ObjectId
Returns the object ID of the appended vertex.
Remarks
If this polyline entity is database-resident, the vertex entity is made database-resident. If this polyline entity is not database-resident, the vertex entity is made database-resident when this polyline entity is made database-resident. If this Polyline is database-resident, the vertex entity must explicitly be closed when appendVertex() returns.
See Also

©  Bricsys NV. All rights reserved.