MaterialNormalMapComponentEquality Operator

Equality operator for the MaterialNormalMapComponent structure. Checks whether input normal map components are equal.

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public static bool operator ==(
        MaterialNormalMapComponent a,
        MaterialNormalMapComponent b
)

Parameters

a  MaterialNormalMapComponent
[in] Left normal map component to compare.
b  MaterialNormalMapComponent
[in] Right normal map component to compare.

Return Value

Boolean
true only if the following conditions are met: * Methods used to calculate normal maps are equal (both can be nullptr). * Strength values of normal maps are equal.
See Also

©  Bricsys NV. All rights reserved.