MaterialNormalMapComponent Structure

This class stores the material map for the normal map channel of the material, the method used to compute the normal map, and the channel strength.
Inheritance Hierarchy
SystemObject
  SystemValueType
    Teigha.GraphicsInterfaceMaterialNormalMapComponent

Namespace: Teigha.GraphicsInterface
Assembly: TD_Mgd (in TD_Mgd.dll) Version: 24.2.0.0
Syntax
public struct MaterialNormalMapComponent

The MaterialNormalMapComponent type exposes the following members.

Constructors
  Name Description
Public method MaterialNormalMapComponent Constructor for the MaterialNormalMapComponent class. Constructs an object with the specified material map, method used to compute the normal map and the channel strength.
Top
Properties
  Name Description
Public property Map  
Public property Method  
Public property Strength  
Top
Methods
  Name Description
Public method Equals Checks objects for equality.
(Overrides ValueTypeEquals(Object))
Public method GetHashCode Retrieves the object hash code.
(Overrides ValueTypeGetHashCode)
Public method ToString Returns an equivalent string representation of this object.
(Overrides ValueTypeToString)
Public method ToString(IFormatProvider) Returns an equivalent string representation of this object.
Top
Operators
  Name Description
Public operatorStatic member Equality(MaterialNormalMapComponent, MaterialNormalMapComponent) Equality operator for the MaterialNormalMapComponent structure. Checks whether input normal map components are equal.
Public operatorStatic member Inequality(MaterialNormalMapComponent, MaterialNormalMapComponent) Inequality operator for the MaterialNormalMapComponent structure. Checks whether input normal map components are not equal.
Top
See Also

©  Bricsys NV. All rights reserved.