Returns the matrix that scales by a scale
factor about the center.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public static Matrix3d Scaling(
double scaleAll,
Point3d center
)
Public Shared Function Scaling (
scaleAll As Double,
center As Point3d
) As Matrix3d
public:
static Matrix3d Scaling(
double scaleAll,
Point3d center
)
static member Scaling :
scaleAll : float *
center : Point3d -> Matrix3d
Parameters
- scaleAll Double
- [in] Scale factor.
- center Point3d
- [in] Point about which to scale.
Return Value
Matrix3d
See Also