NurbCurve3dSetWeightAt Method
|
Sets the weight at the specified index.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public void SetWeightAt(
int index,
double value
)
Public Sub SetWeightAt (
index As Integer,
value As Double
)
public:
void SetWeightAt(
int index,
double value
)
member SetWeightAt :
index : int *
value : float -> unit
Parameters
- index Int32
- [in] Weight index.
- value Double
- [in] Weight at the specified fit point.
Remarks
The closer the
weight value is to zero, the closer the curve is to a straight line
near the corresponding control point. If the weight increases, the
curve pulls toward the corresponding control point. If the weight
decreases, the curve pushes from the corresponding control
point.
See Also