MPolygonEvaluateHatch Method
|
Evaluates the lines or solid fill for the
hatch entity using the specified hatch pattern.
Namespace: Teigha.DatabaseServices
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public virtual void EvaluateHatch(
bool underEstimateNumberOfLines
)
Public Overridable Sub EvaluateHatch (
underEstimateNumberOfLines As Boolean
)
public:
virtual void EvaluateHatch(
bool underEstimateNumberOfLines
)
abstract EvaluateHatch :
underEstimateNumberOfLines : bool -> unit
override EvaluateHatch :
underEstimateNumberOfLines : bool -> unit
Parameters
- underEstimateNumberOfLines Boolean
- [in] Flag that specifies whether to underestimate the hatch
count before aborting.
Remarks
If
'underEstimateNumberOfLines' is true, the method aborts if the
number of lines in the pattern exceeds the maximum allowed hatch
line density. By default, the maximum allowed hatch line density is
100000 unless a corresponding value is set for the MAXHATCHDENSITY
variable.
See Also