Matrix3dIsSingular(Tolerance) Method
|
Checks whether this matrix is singular
according to the specified tolerance.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public bool IsSingular(
Tolerance tolerance
)
Public Function IsSingular (
tolerance As Tolerance
) As Boolean
public:
bool IsSingular(
Tolerance tolerance
)
member IsSingular :
tolerance : Tolerance -> bool
Parameters
- tolerance Tolerance
- [in] Geometric tolerance.
Return Value
Boolean
true if this matrix is singular, false otherwise.
Remarks
* A matrix is
singular if and only if its determinant == 0. * A singular matrix
cannot be inverted.
See Also