Rotates this point about the specified point
by the specified angle.
Namespace: Teigha.Geometry
Assembly: TD_Mgd (in TD_Mgd.dll) Version:
24.2.0.0
Syntax
public Point2d RotateBy(
double angle,
Point2d origin
)
Public Function RotateBy (
angle As Double,
origin As Point2d
) As Point2d
public:
Point2d RotateBy(
double angle,
Point2d origin
)
member RotateBy :
angle : float *
origin : Point2d -> Point2d
Parameters
- angle Double
- [in] Rotation angle in radians.
- origin Point2d
- [in] Point relative to which rotation is computed.
Return Value
Point2d
2D point that is the result of the rotation operation.
See Also